aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/image')
-rw-r--r--target/linux/ar71xx/image/generic.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 6ceabeb288..e2867e6c40 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -484,6 +484,24 @@ define Device/som9331
endef
TARGET_DEVICES += som9331
+define Device/sr3200
+ DEVICE_TITLE := YunCore SR3200
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-ath10k ath10k-firmware-qca988x
+ BOARDNAME = SR3200
+ IMAGE_SIZE = 16000k
+ CONSOLE = ttyS0,115200
+ MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env),16000k(firmware),64k(art)ro
+endef
+TARGET_DEVICES += sr3200
+
+define Device/xd3200
+ $(Device/sr3200)
+ DEVICE_TITLE := YunCore XD3200
+ DEVICE_PACKAGES := kmod-ath10k ath10k-firmware-qca988x
+ BOARDNAME = XD3200
+endef
+TARGET_DEVICES += xd3200
+
define Device/tellstick-znet-lite
$(Device/tplink-16mlzma)
DEVICE_TITLE := TellStick ZNet Lite