aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/nand.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/image/nand.mk')
-rw-r--r--target/linux/ar71xx/image/nand.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/nand.mk b/target/linux/ar71xx/image/nand.mk
index 15e0809120..dfe78c2168 100644
--- a/target/linux/ar71xx/image/nand.mk
+++ b/target/linux/ar71xx/image/nand.mk
@@ -52,6 +52,20 @@ define Build/MerakiNAND-old
@mv $@.new $@
endef
+define Device/rambutan
+ DEVICE_TITLE := 8devices Rambutan
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2
+ BOARDNAME = RAMBUTAN
+ BLOCKSIZE = 128KiB
+ MTDPARTS = ar934x-nfc:3M(u-boot)ro,2M(u-boot-env),1M(art),122M(ubi)
+ PAGESIZE := 2048
+ KERNEL_IN_UBI := 1
+ IMAGES := factory.ubi sysupgrade.tar
+ IMAGE/sysupgrade.tar := sysupgrade-tar
+ IMAGE/factory.ubi := append-ubi
+endef
+TARGET_DEVICES += rambutan
+
define Device/z1
DEVICE_TITLE := Meraki Z1
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-spi-gpio kmod-ath9k kmod-owl-loader