aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/nand.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/image/nand.mk')
-rw-r--r--target/linux/ar71xx/image/nand.mk33
1 files changed, 17 insertions, 16 deletions
diff --git a/target/linux/ar71xx/image/nand.mk b/target/linux/ar71xx/image/nand.mk
index 3b8ce617cd..05e043f542 100644
--- a/target/linux/ar71xx/image/nand.mk
+++ b/target/linux/ar71xx/image/nand.mk
@@ -1,3 +1,20 @@
+define Build/MerakiNAND
+ -$(STAGING_DIR_HOST)/bin/mkmerakifw \
+ -B $(BOARDNAME) -s \
+ -i $@ \
+ -o $@.new
+ @mv $@.new $@
+endef
+
+define Build/MerakiNAND-old
+ -$(STAGING_DIR_HOST)/bin/mkmerakifw-old \
+ -B $(BOARDNAME) -s \
+ -i $@ \
+ -o $@.new
+ @mv $@.new $@
+endef
+
+
define Device/c-60
DEVICE_TITLE := AirTight C-60
DEVICE_PACKAGES := kmod-spi-gpio kmod-usb-core kmod-usb2 kmod-ath9k
@@ -41,14 +58,6 @@ define Device/hiveap-121
endef
TARGET_DEVICES += hiveap-121
-define Build/MerakiNAND
- -$(STAGING_DIR_HOST)/bin/mkmerakifw \
- -B $(BOARDNAME) -s \
- -i $@ \
- -o $@.new
- @mv $@.new $@
-endef
-
define Device/mr18
DEVICE_TITLE := Meraki MR18
DEVICE_PACKAGES := kmod-spi-gpio kmod-ath9k
@@ -62,14 +71,6 @@ define Device/mr18
endef
TARGET_DEVICES += mr18
-define Build/MerakiNAND-old
- -$(STAGING_DIR_HOST)/bin/mkmerakifw-old \
- -B $(BOARDNAME) -s \
- -i $@ \
- -o $@.new
- @mv $@.new $@
-endef
-
define Device/rambutan
DEVICE_TITLE := 8devices Rambutan
DEVICE_PACKAGES := kmod-usb-core kmod-usb2