aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/image/generic.mk')
-rw-r--r--target/linux/ar71xx/image/generic.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 34bb7da84d..37ffbe7ffa 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -85,6 +85,14 @@ define Device/cf-e530n
endef
TARGET_DEVICES += cf-e530n
+define Device/cpe505n
+ DEVICE_TITLE := P&W CPE505N
+ BOARDNAME = CPE505N
+ IMAGE_SIZE = 16000k
+ MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,16000k(firmware),64k(art)ro
+endef
+TARGET_DEVICES += cpe505n
+
define Device/cpe830
$(Device/ap90q)
DEVICE_TITLE := YunCore CPE830
@@ -426,6 +434,15 @@ define Device/jwap230
endef
TARGET_DEVICES += jwap230
+define Device/r602n
+ DEVICE_TITLE := P&W R602N
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2
+ BOARDNAME = R602N
+ IMAGE_SIZE = 16000k
+ MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,16000k(firmware),64k(art)ro
+endef
+TARGET_DEVICES += r602n
+
define Device/rnx-n360rt
$(Device/tplink-4m)
DEVICE_TITLE := Rosewill RNX-N360RT