aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/image/generic.mk')
-rw-r--r--target/linux/ar71xx/image/generic.mk19
1 files changed, 19 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index c74ca130b6..54f69b610b 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -334,6 +334,25 @@ define Device/e1700ac-v2-8M
endef
TARGET_DEVICES += e1700ac-v2-8M
+define Device/e558-v2-16M
+ DEVICE_TITLE := Qxwlan E558 v2 (16MB flash)
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 -swconfig
+ BOARDNAME := E558-V2
+ SUPPORTED_DEVICES := e558-v2
+ IMAGE_SIZE := 15936k
+ MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),64k(pri-data)ro,64k(art),-(firmware)
+ IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) |\
+ append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += e558-v2-16M
+
+define Device/e558-v2-8M
+ $(Device/e558-v2-16M)
+ DEVICE_TITLE := Qxwlan E558 v2 (8MB flash)
+ IMAGE_SIZE := 7744k
+endef
+TARGET_DEVICES += e558-v2-8M
+
define Device/e600g-v2-16M
DEVICE_TITLE := Qxwlan E600G v2 (16MB flash)
DEVICE_PACKAGES := kmod-usb-core kmod-usb2 -swconfig