aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/image/generic.mk')
-rw-r--r--target/linux/ar71xx/image/generic.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 726b03a04c..3352d156ac 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -874,6 +874,9 @@ define Device/wpj344
$(Device/wpj-16m)
DEVICE_TITLE := Compex WPJ344 (16MB flash)
BOARDNAME := WPJ344
+ SUPPORTED_DEVICES := wpj344
+ IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
endef
define Device/wpj531
@@ -886,6 +889,9 @@ define Device/wpj558
$(Device/wpj-16m)
DEVICE_TITLE := Compex WPJ558 (16MB flash)
BOARDNAME := WPJ558
+ SUPPORTED_DEVICES := wpj558
+ IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
endef
define Device/wpj563