aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/image/generic.mk')
-rw-r--r--target/linux/ar71xx/image/generic.mk13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 01c5bdc677..f0b2179f44 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -278,6 +278,19 @@ define Device/gl-mifi
endef
TARGET_DEVICES += gl-mifi
+define Device/gl-usb150
+ DEVICE_TITLE := GL.iNet GL-USB150
+ DEVICE_PACKAGES := -swconfig
+ BOARDNAME := GL-USB150
+ IMAGE_SIZE := 16000k
+ CONSOLE := ttyATH0,115200
+ MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,16000k(firmware),64k(art)ro
+ SUPPORTED_DEVICES := gl-usb150
+ IMAGE/sysupgrade.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += gl-usb150
+
define Device/lima
DEVICE_TITLE := 8devices Lima
DEVICE_PACKAGES := kmod-usb-core kmod-usb2