aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/image/generic.mk
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/image/generic.mk')
-rw-r--r--target/linux/ar71xx/image/generic.mk9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 3c5fcc3f3c..eb6d6e5342 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -349,6 +349,15 @@ define Device/mr16
endef
TARGET_DEVICES += mr12 mr16
+define Device/dr342
+ DEVICE_TITLE := Wallys DR342
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 -swconfig
+ BOARDNAME := DR342
+ IMAGE_SIZE := 16000k
+ MTDPARTS := spi0.0:192k(u-boot)ro,64k(u-boot-env),64k(partition-table)ro,16000k(firmware),64k(art)ro
+endef
+TARGET_DEVICES += dr342
+
define Device/dr344
DEVICE_TITLE := Wallys DR344
BOARDNAME := DR344