aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/files/arch
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/files/arch')
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt11
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-wpa8630.c164
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h1
4 files changed, 177 insertions, 0 deletions
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index 86df292dd8..60f6d9a978 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -1707,3 +1707,14 @@ config ATH79_MACH_DAP_2695_A1
select ATH79_DEV_LEDS_GPIO
select ATH79_DEV_M25P80
select ATH79_DEV_WMAC
+
+config ATH79_MACH_WPA8630
+ bool "TP-Link WPA8630 support"
+ select SOC_QCA956X
+ select ATH79_DEV_AP9X_PCI if PCI
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_WMAC
+
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index 4b927bcc3b..cbfd7a4506 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -200,6 +200,7 @@ obj-$(CONFIG_ATH79_MACH_WNR2000_V3) += mach-wnr2000-v3.o
obj-$(CONFIG_ATH79_MACH_WNR2000_V4) += mach-wnr2000-v4.o
obj-$(CONFIG_ATH79_MACH_WNR2200) += mach-wnr2200.o
obj-$(CONFIG_ATH79_MACH_WP543) += mach-wp543.o
+obj-$(CONFIG_ATH79_MACH_WPA8630) += mach-wpa8630.o
obj-$(CONFIG_ATH79_MACH_WPE72) += mach-wpe72.o
obj-$(CONFIG_ATH79_MACH_WPJ342) += mach-wpj342.o
obj-$(CONFIG_ATH79_MACH_WPJ344) += mach-wpj344.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-wpa8630.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-wpa8630.c
new file mode 100644
index 0000000000..d86adaf27b
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-wpa8630.c
@@ -0,0 +1,164 @@
+/*
+ * TP-Link WPA8630 board support
+ *
+ * Copyright (C) 2016 Henryk Heisig <hyniu@o2.pl>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+#include <linux/platform_device.h>
+#include <linux/ath9k_platform.h>
+#include <linux/ar8216_platform.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-m25p80.h"
+#include "machtypes.h"
+#include "pci.h"
+#include "dev-ap9x-pci.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-spi.h"
+#include "dev-wmac.h"
+
+#define WPA8630_KEYS_POLL_INTERVAL 20
+#define WPA8630_KEYS_DEBOUNCE_INTERVAL (3 * WPA8630_KEYS_POLL_INTERVAL)
+
+#define WPA8630_GPIO_LED_POWER 1
+#define WPA8630_GPIO_LED_LAN 5
+#define WPA8630_GPIO_LED_WLAN 19
+#define WPA8630_GPIO_LED_WLAN5 21
+
+#define WPA8630_GPIO_BTN_RESET 2
+#define WPA8630_GPIO_BTN_RFKILL 8
+#define WPA8630_GPIO_BTN_0 6
+#define WPA8630_GPIO_BTN_1 7
+
+#define WPA8630_MAC0_OFFSET 0x0000
+#define WPA8630_WMAC_CALDATA_OFFSET 0x1000
+#define WPA8630_PCI_CALDATA_OFFSET 0x5000
+
+static struct flash_platform_data wpa8630_flash_data = {
+ .type = "s25fl064k",
+};
+
+static struct gpio_led wpa8630_leds_gpio[] __initdata = {
+ {
+ .name = "wpa8630:green:power",
+ .gpio = WPA8630_GPIO_LED_POWER,
+ .active_low = 1,
+ },
+ {
+ .name = "wpa8630:green:lan",
+ .gpio = WPA8630_GPIO_LED_LAN,
+ .active_low = 1,
+ },
+ {
+ .name = "wpa8630:green:wlan",
+ .gpio = WPA8630_GPIO_LED_WLAN,
+ .active_low = 1,
+ },
+ {
+ .name = "wpa8630:green:wlan5",
+ .gpio = WPA8630_GPIO_LED_WLAN5,
+ .active_low = 1,
+ },
+};
+
+static struct gpio_keys_button wpa8630_gpio_keys[] __initdata = {
+ {
+ .desc = "Reset button",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = WPA8630_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = WPA8630_GPIO_BTN_RESET,
+ .active_low = 1,
+ },
+ {
+ .desc = "RFKILL button",
+ .type = EV_KEY,
+ .code = KEY_RFKILL,
+ .debounce_interval = WPA8630_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = WPA8630_GPIO_BTN_RFKILL,
+ .active_low = 1,
+ },
+ {
+ .desc = "LED",
+ .type = EV_KEY,
+ .debounce_interval = WPA8630_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = WPA8630_GPIO_BTN_0,
+ .active_low = 1,
+ },
+ {
+ .desc = "Pair",
+ .type = EV_KEY,
+ .debounce_interval = WPA8630_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = WPA8630_GPIO_BTN_1,
+ .active_low = 1,
+ },
+};
+
+/* GMAC0 of the QCA8337 switch is connected to the QCA9563 SoC via SGMII */
+static struct ar8327_pad_cfg wpa8630_qca8337_pad0_cfg = {
+ .mode = AR8327_PAD_MAC_SGMII,
+ .sgmii_delay_en = true,
+};
+
+static struct ar8327_platform_data wpa8630_qca8337_data = {
+ .pad0_cfg = &wpa8630_qca8337_pad0_cfg,
+ .port0_cfg = {
+ .force_link = 1,
+ .speed = AR8327_PORT_SPEED_1000,
+ .duplex = 1,
+ .txpause = 1,
+ .rxpause = 1,
+ },
+};
+
+static struct mdio_board_info wpa8630_mdio0_info[] = {
+ {
+ .bus_id = "ag71xx-mdio.0",
+ .phy_addr = 0,
+ .platform_data = &wpa8630_qca8337_data,
+ },
+};
+
+static void __init wpa8630_setup(void)
+{
+ u8 *mac = (u8 *) KSEG1ADDR(0x1f00fc00);
+ u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);
+
+ ath79_register_m25p80(&wpa8630_flash_data);
+
+ ath79_init_mac(ath79_eth0_data.mac_addr,
+ art + WPA8630_MAC0_OFFSET, 0);
+
+ platform_device_register(&ath79_mdio0_device);
+
+ mdiobus_register_board_info(wpa8630_mdio0_info,
+ ARRAY_SIZE(wpa8630_mdio0_info));
+
+ /* GMAC0 is connected to an AR8337 switch */
+ ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_SGMII;
+ ath79_eth0_data.mii_bus_dev = &ath79_mdio0_device.dev;
+ ath79_eth0_data.phy_mask = ~BIT(4);
+ ath79_init_mac(ath79_eth0_data.mac_addr, mac, 0);
+
+ ath79_register_eth(0);
+
+ ath79_register_wmac(art + WPA8630_WMAC_CALDATA_OFFSET, mac);
+
+ ap91_pci_init(art + WPA8630_PCI_CALDATA_OFFSET, NULL);
+
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(wpa8630_leds_gpio),
+ wpa8630_leds_gpio);
+
+ ath79_register_gpio_keys_polled(-1, WPA8630_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(wpa8630_gpio_keys),
+ wpa8630_gpio_keys);
+}
+
+MIPS_MACHINE(ATH79_MACH_WPA8630, "WPA8630", "TP-Link WPA8630",
+ wpa8630_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index 1243409159..d252a2bc44 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -258,6 +258,7 @@ enum ath79_mach_type {
ATH79_MACH_WNR2200, /* NETGEAR WNR2200 */
ATH79_MACH_WNR612_V2, /* NETGEAR WNR612 v2 */
ATH79_MACH_WP543, /* Compex WP543 */
+ ATH79_MACH_WPA8630, /* TP-Link WPA8630 */
ATH79_MACH_WPE72, /* Compex WPE72 */
ATH79_MACH_WPJ342, /* Compex WPJ342 */
ATH79_MACH_WPJ344, /* Compex WPJ344 */