aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/ar71xx/files/arch/mips
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/ar71xx/files/arch/mips')
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt9
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-fritz300e.c132
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h1
4 files changed, 143 insertions, 0 deletions
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index 6182a6f47f..0df5a88dc3 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -2061,3 +2061,12 @@ config ATH79_MACH_TL_WPA8630
select ATH79_DEV_LEDS_GPIO
select ATH79_DEV_M25P80
select ATH79_DEV_WMAC
+
+config ATH79_MACH_FRITZ300E
+ bool "AVM FRITZ!WLAN Repeater 300E support"
+ select SOC_AR724X
+ select ATH79_DEV_AP9X_PCI if PCI
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index 5c22fafe51..5a848d0399 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -111,6 +111,7 @@ obj-$(CONFIG_ATH79_MACH_ESR1750) += mach-esr1750.o
obj-$(CONFIG_ATH79_MACH_ESR900) += mach-esr900.o
obj-$(CONFIG_ATH79_MACH_EW_DORIN) += mach-ew-dorin.o
obj-$(CONFIG_ATH79_MACH_F9K1115V2) += mach-f9k1115v2.o
+obj-$(CONFIG_ATH79_MACH_FRITZ300E) += mach-fritz300e.o
obj-$(CONFIG_ATH79_MACH_GL_AR150) += mach-gl-ar150.o
obj-$(CONFIG_ATH79_MACH_GL_AR300) += mach-gl-ar300.o
obj-$(CONFIG_ATH79_MACH_GL_AR300M) += mach-gl-ar300m.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-fritz300e.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-fritz300e.c
new file mode 100644
index 0000000000..43af71a0a8
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-fritz300e.c
@@ -0,0 +1,132 @@
+/*
+ * AVM FRITZ!WLAN Repeater 300E board support
+ *
+ * Copyright (C) 2017 Mathias Kresin <dev@kresin.me>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+#include <linux/mtd/mtd.h>
+#include <linux/mtd/partitions.h>
+
+#include "dev-ap9x-pci.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "machtypes.h"
+
+#define FRITZ300E_KEYS_POLL_INTERVAL 20 /* msecs */
+#define FRITZ300E_KEYS_DEBOUNCE_INTERVAL (3 * FRITZ300E_KEYS_POLL_INTERVAL)
+
+static struct mtd_partition fritz300e_flash_partitions[] = {
+ {
+ .name = "urloader",
+ .offset = 0,
+ .size = 0x0020000,
+ .mask_flags = MTD_WRITEABLE,
+ }, {
+ .name = "firmware",
+ .offset = 0x0020000,
+ .size = 0x0ee0000,
+ }, {
+ .name = "tffs (1)",
+ .offset = 0x0f00000,
+ .size = 0x0080000,
+ .mask_flags = MTD_WRITEABLE,
+ }, {
+ .name = "tffs (2)",
+ .offset = 0x0f80000,
+ .size = 0x0080000,
+ .mask_flags = MTD_WRITEABLE,
+ }
+};
+
+static struct flash_platform_data fritz300e_flash_data = {
+ .parts = fritz300e_flash_partitions,
+ .nr_parts = ARRAY_SIZE(fritz300e_flash_partitions),
+};
+
+static struct gpio_led fritz300e_leds_gpio[] __initdata = {
+ {
+ .name = "fritz300e:green:power",
+ .gpio = 13,
+ .active_low = 1,
+ }, {
+ .name = "fritz300e:green:lan",
+ .gpio = 15,
+ .active_low = 1,
+ }, {
+ .name = "fritz300e:green:wlan",
+ .gpio = 16,
+ .active_low = 1,
+ }
+};
+
+static struct gpio_led fritz300e_wmac_leds_gpio[] = {
+ {
+ .name = "fritz300e:green:rssi0",
+ .gpio = 10,
+ .active_low = 1,
+ }, {
+ .name = "fritz300e:green:rssi1",
+ .gpio = 4,
+ .active_low = 1,
+ }, {
+ .name = "fritz300e:green:rssi2",
+ .gpio = 6,
+ .active_low = 1,
+ }, {
+ .name = "fritz300e:green:rssi3",
+ .gpio = 7,
+ .active_low = 1,
+ }, {
+ .name = "fritz300e:green:rssi4",
+ .gpio = 5,
+ .active_low = 1,
+ }
+};
+
+static struct gpio_keys_button fritz300e_gpio_keys[] __initdata = {
+ {
+ .desc = "wps",
+ .type = EV_KEY,
+ .code = KEY_WPS_BUTTON,
+ .debounce_interval = FRITZ300E_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = 12,
+ .active_low = 1,
+ },
+};
+
+static void __init fritz300e_setup(void)
+{
+ /* get the Lantiq PEF7071V phy out of reset */
+ gpio_request_one(11, GPIOF_OUT_INIT_HIGH, "phy reset");
+
+ ath79_register_m25p80(&fritz300e_flash_data);
+
+ ath79_register_mdio(0, ~(BIT(0)));
+
+ ath79_eth0_data.phy_if_mode = PHY_INTERFACE_MODE_RGMII;
+ ath79_eth0_data.speed = SPEED_1000;
+ ath79_eth0_data.duplex = DUPLEX_FULL;
+ ath79_eth0_data.phy_mask = BIT(0);
+
+ ath79_register_eth(0);
+
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(fritz300e_leds_gpio),
+ fritz300e_leds_gpio);
+ ath79_register_gpio_keys_polled(-1, FRITZ300E_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(fritz300e_gpio_keys),
+ fritz300e_gpio_keys);
+
+ ap9x_pci_setup_wmac_leds(0, fritz300e_wmac_leds_gpio,
+ ARRAY_SIZE(fritz300e_wmac_leds_gpio));
+ ap91_pci_init_simple();
+}
+
+MIPS_MACHINE(ATH79_MACH_FRITZ300E, "FRITZ300E",
+ "AVM FRITZ!WLAN Repeater 300E", fritz300e_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index 19d06c9834..8d0dfd662b 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -103,6 +103,7 @@ enum ath79_mach_type {
ATH79_MACH_EW_DORIN, /* embedded wireless Dorin Platform */
ATH79_MACH_EW_DORIN_ROUTER, /* embedded wireless Dorin Router Platform */
ATH79_MACH_F9K1115V2, /* Belkin AC1750DB */
+ ATH79_MACH_FRITZ300E, /* AVM FRITZ!WLAN Repeater 300E */
ATH79_MACH_GL_AR150, /* GL-AR150 support */
ATH79_MACH_GL_AR300, /* GL-AR300 */
ATH79_MACH_GL_AR300M, /* GL-AR300M */