aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/apm821xx')
-rw-r--r--target/linux/apm821xx/Makefile2
-rw-r--r--target/linux/apm821xx/dts/wd-mybooklive.dts5
-rw-r--r--target/linux/apm821xx/sata/config-default2
3 files changed, 7 insertions, 2 deletions
diff --git a/target/linux/apm821xx/Makefile b/target/linux/apm821xx/Makefile
index f36274bd98..875ff225a9 100644
--- a/target/linux/apm821xx/Makefile
+++ b/target/linux/apm821xx/Makefile
@@ -21,6 +21,6 @@ include $(INCLUDE_DIR)/target.mk
KERNELNAME:=uImage
DEFAULT_PACKAGES += \
- kmod-leds-gpio kmod-i2c-core kmod-gpio-button-hotplug
+ kmod-leds-gpio kmod-i2c-core kmod-gpio-button-hotplug uboot-envtools
$(eval $(call BuildTarget))
diff --git a/target/linux/apm821xx/dts/wd-mybooklive.dts b/target/linux/apm821xx/dts/wd-mybooklive.dts
index 2cc4dd8b79..5fcddb0cd8 100644
--- a/target/linux/apm821xx/dts/wd-mybooklive.dts
+++ b/target/linux/apm821xx/dts/wd-mybooklive.dts
@@ -22,7 +22,7 @@
ebc {
nor_flash@0,0 {
status = "okay";
- compatible = "amd,s29gl512n", "jedec-probe", "cfi-flash", "mtd-rom";
+ compatible = "microchip,sst39vf040", "jedec-flash";
bank-width = <1>;
reg = <0x00000000 0x00000000 0x00080000>;
#address-cells = <1>;
@@ -32,16 +32,19 @@
/* Part of bootrom - Don't use it without a jump */
label = "free";
reg = <0x00000000 0x0001e000>;
+ read-only;
};
partition@1e000 {
label = "env";
reg = <0x0001e000 0x00002000>;
+ read-only;
};
partition@20000 {
label = "uboot";
reg = <0x00020000 0x00050000>;
+ read-only;
};
};
};
diff --git a/target/linux/apm821xx/sata/config-default b/target/linux/apm821xx/sata/config-default
index e8e595641d..563fa60478 100644
--- a/target/linux/apm821xx/sata/config-default
+++ b/target/linux/apm821xx/sata/config-default
@@ -35,6 +35,8 @@ CONFIG_MD_RAID0=y
CONFIG_MD_RAID1=y
# CONFIG_MD_RAID10 is not set
# CONFIG_MD_RAID456 is not set
+CONFIG_MTD_PHYSMAP=y
+CONFIG_MTD_JEDECPROBE=y
CONFIG_PM=y
CONFIG_PM_AUTOSLEEP=y
CONFIG_PM_CLK=y