aboutsummaryrefslogtreecommitdiffstats
path: root/target/linux/apm821xx/sata
diff options
context:
space:
mode:
Diffstat (limited to 'target/linux/apm821xx/sata')
-rw-r--r--target/linux/apm821xx/sata/config-default6
-rw-r--r--target/linux/apm821xx/sata/target.mk4
2 files changed, 8 insertions, 2 deletions
diff --git a/target/linux/apm821xx/sata/config-default b/target/linux/apm821xx/sata/config-default
index 7ca6bd4d3d..4c7c655233 100644
--- a/target/linux/apm821xx/sata/config-default
+++ b/target/linux/apm821xx/sata/config-default
@@ -16,6 +16,11 @@ CONFIG_GENERIC_PHY=y
CONFIG_SATA_DWC=y
# CONFIG_SATA_DWC_DEBUG is not set
CONFIG_EXT4_FS=y
+# CONFIG_F2FS_CHECK_FS is not set
+CONFIG_F2FS_FS=y
+# CONFIG_F2FS_FS_SECURITY is not set
+CONFIG_F2FS_FS_XATTR=y
+CONFIG_F2FS_STAT_FS=y
CONFIG_SCSI=y
CONFIG_BLK_DEV_SD=y
CONFIG_GPIOLIB=y
@@ -23,6 +28,7 @@ CONFIG_GPIO_GENERIC=y
CONFIG_GPIO_GENERIC_PLATFORM=y
CONFIG_GPIO_74XX_MMIO=y
CONFIG_LEDS_TRIGGER_DISK=y
+CONFIG_BLK_DEV_LOOP=y
CONFIG_BLK_DEV_DM=y
CONFIG_BLK_DEV_DM_BUILTIN=y
CONFIG_BLK_DEV_MD=y
diff --git a/target/linux/apm821xx/sata/target.mk b/target/linux/apm821xx/sata/target.mk
index 1c7856828c..a5107f1067 100644
--- a/target/linux/apm821xx/sata/target.mk
+++ b/target/linux/apm821xx/sata/target.mk
@@ -1,7 +1,7 @@
BOARDNAME := Devices which boot from SATA (NAS)
-FEATURES += ext4 usb ramdisk
+FEATURES += ext4 usb ramdisk squashfs
DEFAULT_PACKAGES += badblocks block-mount e2fsprogs \
- kmod-dm kmod-md-mod partx-utils
+ kmod-dm kmod-md-mod partx-utils mkf2fs f2fsck
define Target/Description
Build firmware images for APM82181 boards that boot from SATA.