aboutsummaryrefslogtreecommitdiffstats
path: root/target/image/x86/grub/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'target/image/x86/grub/Makefile')
-rw-r--r--target/image/x86/grub/Makefile79
1 files changed, 0 insertions, 79 deletions
diff --git a/target/image/x86/grub/Makefile b/target/image/x86/grub/Makefile
deleted file mode 100644
index e30443e18c..0000000000
--- a/target/image/x86/grub/Makefile
+++ /dev/null
@@ -1,79 +0,0 @@
-#
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id: Makefile 4855 2006-09-24 20:49:31Z nico $
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_NAME:=grub
-PKG_VERSION:=0.97
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=ftp://alpha.gnu.org/gnu/grub
-PKG_MD5SUM:=cd3f3eb54446be6003156158d51f4884
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/grub-$(PKG_VERSION)
-
-include $(INCLUDE_DIR)/package.mk
-
-ifeq ($(HOST_ARCH),x86_64)
- define Build/Configure
- (cd $(PKG_BUILD_DIR); \
- LDFLAGS="-static" \
- ./configure \
- --target=$(GNU_TARGET_NAME) \
- --host=$(GNU_TARGET_NAME) \
- --build=$(GNU_HOST_NAME) \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --sbindir=/usr/sbin \
- --libexecdir=/usr/lib \
- --sysconfdir=/etc \
- --datadir=/usr/share \
- --localstatedir=/var \
- --mandir=/usr/man \
- --infodir=/usr/info \
- $(DISABLE_NLS) \
- )
- endef
-else
- define Build/Configure
- (cd $(PKG_BUILD_DIR); \
- LDFLAGS="-static" \
- ./configure \
- --program-prefix="" \
- --program-suffix="" \
- --prefix=/usr \
- --exec-prefix=/usr \
- --bindir=/usr/bin \
- --sbindir=/usr/sbin \
- --libexecdir=/usr/lib \
- --sysconfdir=/etc \
- --datadir=/usr/share \
- --localstatedir=/var \
- --mandir=/usr/man \
- --infodir=/usr/info \
- )
- endef
-endif
-
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR)
-endef
-
-define Build/InstallDev
- $(MAKE) -C $(PKG_BUILD_DIR) \
- DESTDIR="$(STAGING_DIR)" \
- install
-endef
-
-$(eval $(call Build/DefaultTargets))