aboutsummaryrefslogtreecommitdiffstats
path: root/rules.mk
diff options
context:
space:
mode:
Diffstat (limited to 'rules.mk')
-rw-r--r--rules.mk9
1 files changed, 5 insertions, 4 deletions
diff --git a/rules.mk b/rules.mk
index e54acc9858..b42e19e218 100644
--- a/rules.mk
+++ b/rules.mk
@@ -101,12 +101,13 @@ ifdef CONFIG_MIPS64_ABI
endif
endif
-DEFAULT_SUBDIR_TARGETS:=clean download prepare compile install update refresh prereq dist distcheck configure check
+DEFAULT_SUBDIR_TARGETS:=clean download prepare compile install update refresh prereq dist distcheck configure check check-depends
define DefaultTargets
-$(foreach t,$(DEFAULT_SUBDIR_TARGETS),
- $(t):
- .PHONY: $(t)
+$(foreach t,$(DEFAULT_SUBDIR_TARGETS) $(1),
+ .$(t):
+ $(t): .$(t)
+ .PHONY: $(t) .$(t)
)
endef