aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/block.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/kernel/modules/block.mk b/package/kernel/modules/block.mk
index b9f4c0dbd4..52c528e3e1 100644
--- a/package/kernel/modules/block.mk
+++ b/package/kernel/modules/block.mk
@@ -19,3 +19,14 @@ define KernelPackage/ata-piix
DEPENDS:=+kmod-libata +kmod-ide-core +kmod-scsi-core
endef
$(eval $(call KernelPackage,ata-piix))
+
+define KernelPackage/pata-artop
+ TITLE:=pata-artop
+ DESCRIPTION:=Kernel module for ARTOP PATA controller
+ KCONFIG:=$(CONFIG_PATA_ARTOP)
+ SUBMENU:=$(BLMENU)
+ AUTOLOAD:=$(call AutoLoad,30,libata pata_artop)
+ FILES:=$(LINUX_DIR)/drivers/ata/pata_artop.$(LINUX_KMOD_SUFFIX)
+ DEPENDS:=+kmod-libata +kmod-ide-core +kmod-scsi-core
+endef
+$(eval $(call KernelPackage,pata-artop))