aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/usb.mk10
1 files changed, 0 insertions, 10 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 589894bcd1..f3c84e6f10 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -103,18 +103,8 @@ define KernelPackage/usb-phy-nop
TITLE:=Support for USB NOP transceiver
KCONFIG:=CONFIG_NOP_USB_XCEIV
HIDDEN:=1
-ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/phy/phy-generic.ko),)
FILES:=$(LINUX_DIR)/drivers/usb/phy/phy-generic.ko
AUTOLOAD:=$(call AutoLoad,43,phy-generic)
-else
-ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/phy/phy-nop.ko),)
- FILES:=$(LINUX_DIR)/drivers/usb/phy/phy-nop.ko
- AUTOLOAD:=$(call AutoLoad,43,phy-nop)
-else
- FILES:=$(LINUX_DIR)/drivers/usb/otg/nop-usb-xceiv.ko
- AUTOLOAD:=$(call AutoLoad,43,nop-usb-xceiv)
-endif
-endif
$(call AddDepends/usb)
endef