aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/network/utils/uqmi/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/network/utils/uqmi/Makefile b/package/network/utils/uqmi/Makefile
index c4ca98012a..02265d400c 100644
--- a/package/network/utils/uqmi/Makefile
+++ b/package/network/utils/uqmi/Makefile
@@ -32,7 +32,11 @@ define Package/uqmi/description
endef
TARGET_CFLAGS += \
- -I$(STAGING_DIR)/usr/include -ffunction-sections -fdata-sections
+ -I$(STAGING_DIR)/usr/include \
+ -ffunction-sections \
+ -fdata-sections \
+ -Wno-error=dangling-pointer \
+ -Wno-error=maybe-uninitialized
TARGET_LDFLAGS += -Wl,--gc-sections