aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/network/config/ipip/Makefile2
-rwxr-xr-xpackage/network/config/ipip/files/ipip.sh7
2 files changed, 6 insertions, 3 deletions
diff --git a/package/network/config/ipip/Makefile b/package/network/config/ipip/Makefile
index c262182558..4494e1b81f 100644
--- a/package/network/config/ipip/Makefile
+++ b/package/network/config/ipip/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ipip
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_LICENSE:=GPL-2.0
include $(INCLUDE_DIR)/package.mk
diff --git a/package/network/config/ipip/files/ipip.sh b/package/network/config/ipip/files/ipip.sh
index 15b1c978e3..c433ee0de4 100755
--- a/package/network/config/ipip/files/ipip.sh
+++ b/package/network/config/ipip/files/ipip.sh
@@ -12,7 +12,7 @@ proto_ipip_setup() {
local remoteip
local df ipaddr peeraddr tunlink ttl tos zone mtu
- json_get_vars df ipaddr peeraddr tunlink ttl tos zone mtu
+ json_get_vars df ipaddr peeraddr tunlink ttl tos zone mtu nohostroute
[ -z "$peeraddr" ] && {
proto_notify_error "$cfg" "MISSING_PEER_ADDRESS"
@@ -32,7 +32,9 @@ proto_ipip_setup() {
break
done
- ( proto_add_host_dependency "$cfg" "$peeraddr" "$tunlink" )
+ if [ "${nohostroute}" != "1" ]; then
+ ( proto_add_host_dependency "$cfg" "$peeraddr" "$tunlink" )
+ fi
[ -z "$ipaddr" ] && {
local wanif="$tunlink"
@@ -84,6 +86,7 @@ proto_ipip_init_config() {
proto_config_add_string "ipaddr"
proto_config_add_string "peeraddr"
proto_config_add_boolean "df"
+ proto_config_add_boolean "nohostroute"
}
[ -n "$INCLUDE_ONLY" ] || {