aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/other.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 2d32b4994a..3b41e9d32d 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -71,7 +71,11 @@ define KernelPackage/eeprom-93cx6
TITLE:=EEPROM 93CX6 support
DEPENDS:=@LINUX_2_6
KCONFIG:=CONFIG_EEPROM_93CX6
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.29)),1)
+ FILES:=$(LINUX_DIR)/drivers/misc/eeprom/eeprom_93cx6.$(LINUX_KMOD_SUFFIX)
+else
FILES:=$(LINUX_DIR)/drivers/misc/eeprom_93cx6.$(LINUX_KMOD_SUFFIX)
+endif
AUTOLOAD:=$(call AutoLoad,20,eeprom_93cx6)
endef