aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/boot/uboot-layerscape-32b/Makefile8
-rw-r--r--package/boot/uboot-layerscape/Makefile6
-rw-r--r--package/firmware/fman-ucode/Makefile8
-rw-r--r--package/firmware/rcw/Makefile8
4 files changed, 27 insertions, 3 deletions
diff --git a/package/boot/uboot-layerscape-32b/Makefile b/package/boot/uboot-layerscape-32b/Makefile
index c4e6213ac7..f619186685 100644
--- a/package/boot/uboot-layerscape-32b/Makefile
+++ b/package/boot/uboot-layerscape-32b/Makefile
@@ -16,7 +16,7 @@ PKG_SOURCE_PROTO:=git
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_URL:=https://github.com/fsl-jyt/uboot-ls-32b.git
-PKG_SOURCE_VERSION:=719f8b606334bc73367f78c204dce69786963b65
+PKG_SOURCE_VERSION:=763de09cc7265e3147e2df2e15f91c73231907f4
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
@@ -35,6 +35,11 @@ define uboot/ls1043ardb
CONFIG=ls1043ardb-uboot.bin
endef
+define uboot/ls1046ardb
+ TITLE:=U-Boot binary $(PKG_NAME)-$(PKG_VERSION) for NXP ls1046ardb 32b Dev Board
+ CONFIG=ls1046ardb-uboot.bin
+endef
+
define uboot/ls1012ardb
TITLE:=U-Boot binary $(PKG_NAME)-$(PKG_VERSION) for NXP ls1012ardb 32b Dev Board
CONFIG=ls1012ardb-uboot.bin.swap
@@ -42,6 +47,7 @@ endef
UBOOTS := \
ls1043ardb \
+ ls1046ardb \
ls1012ardb
define Package/uboot/template
diff --git a/package/boot/uboot-layerscape/Makefile b/package/boot/uboot-layerscape/Makefile
index 17fd7f97b0..74c3db83ff 100644
--- a/package/boot/uboot-layerscape/Makefile
+++ b/package/boot/uboot-layerscape/Makefile
@@ -36,6 +36,11 @@ define uboot/ls1043ardb
CONFIG=ls1043ardb
endef
+define uboot/ls1046ardb
+ TITLE:=U-Boot $(PKG_NAME)-$(PKG_VERSION) for NXP ls1046ardb 64b Dev Board
+ CONFIG=ls1046ardb_qspi
+endef
+
define uboot/ls1012ardb
TITLE:=U-Boot $(PKG_NAME)-$(PKG_VERSION) for NXP ls1012ardb 64b Dev Board
CONFIG=ls1012ardb_qspi
@@ -44,6 +49,7 @@ endef
UBOOTS := \
ls1043ardb \
+ ls1046ardb \
ls1012ardb
define Package/uboot/template
diff --git a/package/firmware/fman-ucode/Makefile b/package/firmware/fman-ucode/Makefile
index 216882f664..b0b29ed9cf 100644
--- a/package/firmware/fman-ucode/Makefile
+++ b/package/firmware/fman-ucode/Makefile
@@ -35,8 +35,14 @@ define fman/ls1043ardb
CONFIG=fsl_fman_ucode_ls1043_r1.0_108_4_5.bin
endef
+define fman/ls1046ardb
+ TITLE=FMAN UCODE $(PKG_NAME)-$(PKG_VERSION) for NXP ls1046ardb 64b/32b Dev Board
+ CONFIG=fsl_fman_ucode_t2080_r1.1_106_4_18.bin
+endef
+
FMANS := \
- ls1043ardb
+ ls1043ardb \
+ ls1046ardb
define Package/fman/template
define Package/fman-layerscape-$(1)
diff --git a/package/firmware/rcw/Makefile b/package/firmware/rcw/Makefile
index a412fd9f74..8dfbfe9546 100644
--- a/package/firmware/rcw/Makefile
+++ b/package/firmware/rcw/Makefile
@@ -16,7 +16,7 @@ PKG_SOURCE_PROTO:=git
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_URL:=https://github.com/fsl-jyt/rcw.git
-PKG_SOURCE_VERSION:=e101d1207f402c7b761990a3e6681fdae8f253e3
+PKG_SOURCE_VERSION:=17e09e19bd5cf94e5ebc84916b4607743c29723e
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)-$(BUILD_VARIANT)/$(PKG_NAME)-$(PKG_VERSION)
@@ -35,6 +35,11 @@ define rcw/ls1043ardb
CONFIG=ls1043ardb-rcw.bin
endef
+define rcw/ls1046ardb
+ TITLE=RCW binary $(PKG_NAME)-$(PKG_VERSION) for NXP ls1046ardb 64b/32b Dev Board
+ CONFIG=ls1046ardb-rcw.bin
+endef
+
define rcw/ls1012ardb
TITLE=RCW binary $(PKG_NAME)-$(PKG_VERSION) for NXP ls1012ardb 64b/32b Dev Board
CONFIG=ls1012ardb-rcw.bin
@@ -42,6 +47,7 @@ endef
RCWS := \
ls1043ardb \
+ ls1046ardb \
ls1012ardb
define Package/rcw/template