aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/other.mk1
-rw-r--r--package/spca5xx/Makefile2
2 files changed, 2 insertions, 1 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index d0975e01c7..d644ce5f5a 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -229,6 +229,7 @@ $(eval $(call KernelPackage,softdog))
define KernelPackage/videodev
TITLE=Video4Linux support
DESCRIPTION:=Kernel modules for Video4Linux support
+ DEPENDS:=@VIDEO_SUPPORT
SUBMENU:=$(EMENU)
KCONFIG:=$(CONFIG_VIDEO_DEV)
FILES:=$(MODULES_DIR)/kernel/drivers/media/video/*.$(LINUX_KMOD_SUFFIX)
diff --git a/package/spca5xx/Makefile b/package/spca5xx/Makefile
index 33f4ef0c47..078759bf46 100644
--- a/package/spca5xx/Makefile
+++ b/package/spca5xx/Makefile
@@ -24,7 +24,7 @@ include $(INCLUDE_DIR)/package.mk
define KernelPackage/spca5xx
SUBMENU:=Other modules
- DEPENDS:=kmod-usb-core kmod-videodev
+ DEPENDS:=kmod-usb-core kmod-videodev @VIDEO_SUPPORT
TITLE:=Driver for SPCA5xx based USB cameras
URL:=http://mxhaard.free.fr/
VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)