aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/network/services/hostapd/Config.in22
-rw-r--r--package/network/services/hostapd/Makefile4
2 files changed, 0 insertions, 26 deletions
diff --git a/package/network/services/hostapd/Config.in b/package/network/services/hostapd/Config.in
index 578fba839c..1966067219 100644
--- a/package/network/services/hostapd/Config.in
+++ b/package/network/services/hostapd/Config.in
@@ -1,26 +1,4 @@
# wpa_supplicant config
-config WPA_SUPPLICANT_NO_TIMESTAMP_CHECK
- bool "Disable timestamp check"
- depends on PACKAGE_wpa-supplicant || \
- PACKAGE_wpa-supplicant-openssl || \
- PACKAGE_wpa-supplicant-wolfssl || \
- PACKAGE_wpa-supplicant-mesh-openssl || \
- PACKAGE_wpa-supplicant-mesh-wolfssl || \
- PACKAGE_wpa-supplicant-basic || \
- PACKAGE_wpa-supplicant-mini || \
- PACKAGE_wpa-supplicant-p2p || \
- PACKAGE_wpad || \
- PACKAGE_wpad-openssl || \
- PACKAGE_wpad-wolfssl || \
- PACKAGE_wpad-basic || \
- PACKAGE_wpad-mini || \
- PACKAGE_wpad-mesh-openssl || \
- PACKAGE_wpad-mesh-wolfssl
- default n
- help
- This disables the timestamp check for certificates in wpa_supplicant
- Useful for devices without RTC that cannot reliably get the real date/time
-
config WPA_RFKILL_SUPPORT
bool "Add rfkill support"
depends on PACKAGE_wpa-supplicant || \
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 235f178bc9..e389efccb2 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -22,7 +22,6 @@ PKG_CPE_ID:=cpe:/a:w1.fi:hostapd
PKG_BUILD_PARALLEL:=1
PKG_CONFIG_DEPENDS:= \
- CONFIG_WPA_SUPPLICANT_NO_TIMESTAMP_CHECK \
CONFIG_PACKAGE_kmod-ath9k \
CONFIG_PACKAGE_kmod-cfg80211 \
CONFIG_PACKAGE_hostapd \
@@ -123,9 +122,6 @@ ifneq ($(LOCAL_TYPE),hostapd)
endif
endif
- ifdef CONFIG_WPA_SUPPLICANT_NO_TIMESTAMP_CHECK
- TARGET_CFLAGS += -DNO_TIMESTAMP_CHECK
- endif
ifdef CONFIG_WPA_RFKILL_SUPPORT
DRIVER_MAKEOPTS += NEED_RFKILL=y
endif