aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/other.mk47
1 files changed, 47 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index b39a88be4d..3b2d2e9667 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -954,3 +954,50 @@ define KernelPackage/bmp085-spi/description
endef
$(eval $(call KernelPackage,bmp085-spi))
+
+define KernelPackage/tpm
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=TPM Hardware Support
+ KCONFIG:= CONFIG_TCG_TPM
+ FILES:= $(LINUX_DIR)/drivers/char/tpm/tpm.ko
+ AUTOLOAD:=$(call AutoLoad,10,tpm,1)
+endef
+
+define KernelPackage/tpm/description
+ This enables TPM Hardware Support.
+endef
+
+$(eval $(call KernelPackage,tpm))
+
+define KernelPackage/tpm-tis
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=TPM TIS 1.2 Interface / TPM 2.0 FIFO Interface
+ DEPENDS:= @TARGET_x86 +kmod-tpm
+ KCONFIG:= CONFIG_TCG_TIS
+ FILES:= $(LINUX_DIR)/drivers/char/tpm/tpm_tis.ko
+ AUTOLOAD:=$(call AutoLoad,20,tpm_tis,1)
+endef
+
+define KernelPackage/tpm-tis/description
+ If you have a TPM security chip that is compliant with the
+ TCG TIS 1.2 TPM specification (TPM1.2) or the TCG PTP FIFO
+ specification (TPM2.0) say Yes and it will be accessible from
+ within Linux.
+endef
+
+$(eval $(call KernelPackage,tpm-tis))
+
+define KernelPackage/tpm-i2c-atmel
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=TPM I2C Atmel Support
+ DEPENDS:= +kmod-tpm +kmod-i2c-core
+ KCONFIG:= CONFIG_TCG_TIS_I2C_ATMEL
+ FILES:= $(LINUX_DIR)/drivers/char/tpm/tpm_i2c_atmel.ko
+ AUTOLOAD:=$(call AutoLoad,40,tpm_i2c_atmel,1)
+endef
+
+define KernelPackage/tpm-i2c-atmel/description
+ This enables the TPM Interface Specification 1.2 Interface (I2C - Atmel)
+endef
+
+$(eval $(call KernelPackage,tpm-i2c-atmel))