aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/can.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/can.mk b/package/kernel/linux/modules/can.mk
index c2c7411c6e..3bf0359c11 100644
--- a/package/kernel/linux/modules/can.mk
+++ b/package/kernel/linux/modules/can.mk
@@ -146,6 +146,23 @@ endef
$(eval $(call KernelPackage,can-gw))
+define KernelPackage/can-mcp251x
+ TITLE:=MCP251x SPI CAN controller
+ KCONFIG:=\
+ CONFIG_SPI=y \
+ CONFIG_CAN_MCP251X
+ FILES:=$(LINUX_DIR)/drivers/net/can/spi/mcp251x.ko
+ AUTOLOAD:=$(call AutoProbe,can-mcp251x)
+ $(call AddDepends/can)
+endef
+
+define KernelPackage/can-mcp251x/description
+ Microchip MCP251x SPI CAN controller
+endef
+
+$(eval $(call KernelPackage,can-mcp251x))
+
+
define KernelPackage/can-raw
TITLE:=Raw CAN Protcol
KCONFIG:=CONFIG_CAN_RAW