aboutsummaryrefslogtreecommitdiffstats
path: root/package
diff options
context:
space:
mode:
Diffstat (limited to 'package')
-rw-r--r--package/kernel/modules/other.mk17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 9ea0f1885d..fcac951cac 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -103,6 +103,23 @@ endef
$(eval $(call KernelPackage,lp))
+define KernelPackage/pcspkr
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=PC speaker support
+ DEPENDS:=@LINUX_2_6
+ KCONFIG:=CONFIG_INPUT_PCSPKR
+ FILES:= \
+ $(LINUX_DIR)/drivers/input/misc/pcspkr.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,50, \
+ pcspkr \
+ )
+endef
+
+define KernelPackage/pcspkr/description
+ This enables sounds (tones) through the pc speaker
+endef
+
+$(eval $(call KernelPackage,pcspkr))
define KernelPackage/pcmcia-core
SUBMENU:=$(OTHER_MENU)