aboutsummaryrefslogtreecommitdiffstats
path: root/package/wprobe/src/user/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/wprobe/src/user/Makefile')
-rw-r--r--package/wprobe/src/user/Makefile31
1 files changed, 24 insertions, 7 deletions
diff --git a/package/wprobe/src/user/Makefile b/package/wprobe/src/user/Makefile
index e10dfc0d24..01e83da3eb 100644
--- a/package/wprobe/src/user/Makefile
+++ b/package/wprobe/src/user/Makefile
@@ -1,21 +1,38 @@
-CFLAGS = -O2
-CPPFLAGS ?= -I../kernel
-WFLAGS = -Wall -Werror
+include ../Makefile.inc
+
+CPPFLAGS += -I../kernel
LDFLAGS =
+ifneq ($(HOST_OS),Linux)
+USE_LIBNL_MICRO=1
+else
+USE_LIBNL_MICRO=
+endif
+
+ifeq ($(USE_LIBNL_MICRO),1)
+LIBNL_PREFIX = /usr/local
+LIBNL = $(LIBNL_PREFIX)/lib/libnl-micro.a
+CPPFLAGS += -I$(LIBNL_PREFIX)/include/libnl-micro
+EXTRA_CFLAGS += -DNO_LOCAL_ACCESS
+else
LIBNL = -lnl
+endif
+
LIBM = -lm
LIBS = $(LIBNL) $(LIBM)
-all: libwprobe.a wprobe-info
+all: libwprobe.a wprobe-util
-libwprobe.a: wprobe.o
+libwprobe.a: wprobe-lib.o
rm -f $@
$(AR) rcu $@ $^
$(RANLIB) $@
%.o: %.c
- $(CC) $(WFLAGS) -c -o $@ $(CPPFLAGS) $(CFLAGS) $<
+ $(CC) $(WFLAGS) -c -o $@ $(CPPFLAGS) $(CFLAGS) $(EXTRA_CFLAGS) $<
-wprobe-info: wprobe-info.o wprobe.o
+wprobe-util: wprobe-util.o wprobe-lib.o
$(CC) -o $@ $^ $(LDFLAGS) $(LIBS)
+
+clean:
+ rm -f *.o *.a wprobe-util