aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils
diff options
context:
space:
mode:
Diffstat (limited to 'package/utils')
-rw-r--r--package/utils/mtd-utils/patches/010-fix-rpmatch.patch2
-rw-r--r--package/utils/mtd-utils/patches/130-lzma_jffs2.patch6
2 files changed, 4 insertions, 4 deletions
diff --git a/package/utils/mtd-utils/patches/010-fix-rpmatch.patch b/package/utils/mtd-utils/patches/010-fix-rpmatch.patch
index 9d0de7f521..8374a26e9b 100644
--- a/package/utils/mtd-utils/patches/010-fix-rpmatch.patch
+++ b/package/utils/mtd-utils/patches/010-fix-rpmatch.patch
@@ -1,6 +1,6 @@
--- a/include/common.h
+++ b/include/common.h
-@@ -137,10 +137,12 @@ static inline bool prompt(const char *ms
+@@ -152,10 +152,12 @@ static inline bool prompt(const char *ms
}
if (strcmp("\n", line) != 0) {
diff --git a/package/utils/mtd-utils/patches/130-lzma_jffs2.patch b/package/utils/mtd-utils/patches/130-lzma_jffs2.patch
index 8c3794d769..abf05e47f2 100644
--- a/package/utils/mtd-utils/patches/130-lzma_jffs2.patch
+++ b/package/utils/mtd-utils/patches/130-lzma_jffs2.patch
@@ -2,7 +2,7 @@
+++ b/Makefile
@@ -3,7 +3,7 @@
- VERSION = 1.5.1
+ VERSION = 1.5.2
-CPPFLAGS += -D_GNU_SOURCE -I./include -I$(BUILDDIR)/include -I./ubi-utils/include $(ZLIBCPPFLAGS) $(LZOCPPFLAGS) $(UUIDCPPFLAGS)
+CPPFLAGS += -D_GNU_SOURCE -I./include -I$(BUILDDIR)/include -I./ubi-utils/include $(ZLIBCPPFLAGS) $(LZOCPPFLAGS) $(UUIDCPPFLAGS) -I./include/linux/lzma
@@ -122,7 +122,7 @@
+}
+
+STATIC int jffs2_lzma_compress(unsigned char *data_in, unsigned char *cpage_out,
-+ uint32_t *sourcelen, uint32_t *dstlen, void *model)
++ uint32_t *sourcelen, uint32_t *dstlen)
+{
+ SizeT compress_size = (SizeT)(*dstlen);
+ int ret;
@@ -147,7 +147,7 @@
+}
+
+STATIC int jffs2_lzma_decompress(unsigned char *data_in, unsigned char *cpage_out,
-+ uint32_t srclen, uint32_t destlen, void *model)
++ uint32_t srclen, uint32_t destlen)
+{
+ int ret;
+ SizeT dl = (SizeT)destlen;