aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/xfsprogs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/utils/xfsprogs/Makefile')
-rw-r--r--package/utils/xfsprogs/Makefile98
1 files changed, 0 insertions, 98 deletions
diff --git a/package/utils/xfsprogs/Makefile b/package/utils/xfsprogs/Makefile
deleted file mode 100644
index f717185bb6..0000000000
--- a/package/utils/xfsprogs/Makefile
+++ /dev/null
@@ -1,98 +0,0 @@
-#
-# Copyright (C) 2006-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=xfsprogs
-PKG_CPE_ID:=cpe:/a:sgi:xfsprogs
-PKG_RELEASE:=4
-PKG_VERSION:=4.11.0
-PKG_SOURCE_URL:=@KERNEL/linux/utils/fs/xfs/xfsprogs
-PKG_HASH:=c3a6d87b564d7738243c507df82276bed982265e345363a95f2c764e8a5f5bb2
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_INSTALL:=1
-PKG_BUILD_PARALLEL:=1
-
-include $(INCLUDE_DIR)/package.mk
-
-define Package/xfsprogs/default
- SECTION:=utils
- CATEGORY:=Utilities
- SUBMENU:=Filesystem
- DEPENDS:=+libuuid +libpthread +librt
- URL:=http://oss.sgi.com/projects/xfs
-endef
-
-define Package/xfs-admin
-$(call Package/xfsprogs/default)
- TITLE:=Utilities for changing parameters of an XFS filesystems
-endef
-
-define Package/xfs-mkfs
-$(call Package/xfsprogs/default)
- TITLE:=Utility for creating XFS filesystems
-endef
-
-define Package/xfs-fsck
-$(call Package/xfsprogs/default)
- TITLE:=Utilities for checking and repairing XFS filesystems
-endef
-
-define Package/xfs-growfs
-$(call Package/xfsprogs/default)
- TITLE:=Utility for increasing the size of XFS filesystems
-endef
-
-CONFIGURE_ARGS += \
- --enable-gettext=no \
- --enable-lib64=no \
- --enable-blkid=no
-
-TARGET_CFLAGS += \
- -I$(STAGING_DIR)/usr/include \
- -D_LARGEFILE64_SOURCE \
- -D_FILE_OFFSET_BITS=64 \
- -D_GNU_SOURCE
-
-MAKE_FLAGS += \
- DEBUG= Q= \
- PCFLAGS="-Wall" \
- PKG_PLATFORM=linux \
- ENABLE_GETTEXT=no
-
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR)/libxfs crc32table.h CFLAGS="$(HOST_CFLAGS) -I$(PKG_BUILD_DIR)/include"
- $(call Build/Compile/Default)
-endef
-
-define Package/xfs-admin/install
- mkdir -p $(1)/sbin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/xfs_db $(1)/sbin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/xfs_admin $(1)/sbin
-endef
-
-define Package/xfs-mkfs/install
- mkdir -p $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/mkfs.xfs $(1)/usr/sbin
-endef
-
-define Package/xfs-fsck/install
- mkdir -p $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/sbin/xfs_repair $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/xfs_db $(1)/usr/sbin
-endef
-
-define Package/xfs-growfs/install
- mkdir -p $(1)/usr/sbin
- $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/xfs_growfs $(1)/usr/sbin
-endef
-
-$(eval $(call BuildPackage,xfs-admin))
-$(eval $(call BuildPackage,xfs-mkfs))
-$(eval $(call BuildPackage,xfs-fsck))
-$(eval $(call BuildPackage,xfs-growfs))