aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/util-linux
diff options
context:
space:
mode:
Diffstat (limited to 'package/utils/util-linux')
-rw-r--r--package/utils/util-linux/Makefile17
1 files changed, 17 insertions, 0 deletions
diff --git a/package/utils/util-linux/Makefile b/package/utils/util-linux/Makefile
index cf80012879..f037e6a6b5 100644
--- a/package/utils/util-linux/Makefile
+++ b/package/utils/util-linux/Makefile
@@ -303,6 +303,17 @@ define Package/namei/description
files, directories, and so forth)
endef
+define Package/prlimit
+$(call Package/util-linux/Default)
+ TITLE:=get and set process resource limits
+ DEPENDS:= +libsmartcols
+endef
+
+define Package/prlimit/description
+ Given a process id and one or more resources, prlimit tries to retrieve
+ and/or modify the limits.
+endef
+
define Package/rename
$(call Package/util-linux/Default)
TITLE:=rename files
@@ -534,6 +545,11 @@ define Package/namei/install
$(INSTALL_BIN) $(PKG_BUILD_DIR)/namei $(1)/usr/bin/
endef
+define Package/prlimit/install
+ $(INSTALL_DIR) $(1)/usr/bin
+ $(INSTALL_BIN) $(PKG_BUILD_DIR)/.libs/prlimit $(1)/usr/bin/
+endef
+
define Package/rename/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/rename $(1)/usr/bin/
@@ -614,6 +630,7 @@ $(eval $(call BuildPackage,lsblk))
$(eval $(call BuildPackage,mcookie))
$(eval $(call BuildPackage,mount-utils))
$(eval $(call BuildPackage,namei))
+$(eval $(call BuildPackage,prlimit))
$(eval $(call BuildPackage,rename))
$(eval $(call BuildPackage,partx-utils))
$(eval $(call BuildPackage,script-utils))