aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/util-linux/patches/001-no-printf-alloc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/utils/util-linux/patches/001-no-printf-alloc.patch')
-rw-r--r--package/utils/util-linux/patches/001-no-printf-alloc.patch22
1 files changed, 11 insertions, 11 deletions
diff --git a/package/utils/util-linux/patches/001-no-printf-alloc.patch b/package/utils/util-linux/patches/001-no-printf-alloc.patch
index 5acd2f06ed..ad9eef0959 100644
--- a/package/utils/util-linux/patches/001-no-printf-alloc.patch
+++ b/package/utils/util-linux/patches/001-no-printf-alloc.patch
@@ -1,8 +1,8 @@
--- a/configure.ac
+++ b/configure.ac
-@@ -769,7 +769,6 @@ AC_ARG_ENABLE([libmount],
+@@ -798,7 +798,6 @@ AC_ARG_ENABLE([libmount],
+ )
UL_BUILD_INIT([libmount])
- UL_REQUIRES_LINUX([libmount])
UL_REQUIRES_BUILD([libmount], [libblkid])
-UL_REQUIRES_HAVE([libmount], [scanf_alloc_modifier], [scanf string alloc modifier])
AM_CONDITIONAL([BUILD_LIBMOUNT], [test "x$build_libmount" = xyes])
@@ -18,10 +18,10 @@
+# define UL_SCNsA "%s"
+#endif
+
- static inline char *skip_spaces(char *s)
+ static int next_number(char **s, int *num)
{
- assert(s);
-@@ -61,16 +65,31 @@ static int mnt_parse_table_line(struct l
+ char *end = NULL;
+@@ -52,16 +56,31 @@ static int mnt_parse_table_line(struct l
int rc, n = 0, xrc;
char *src = NULL, *fstype = NULL, *optstr = NULL;
@@ -53,7 +53,7 @@
&n);
xrc = rc;
-@@ -136,6 +155,16 @@ static int mnt_parse_mountinfo_line(stru
+@@ -127,6 +146,16 @@ static int mnt_parse_mountinfo_line(stru
unsigned int maj, min;
char *fstype = NULL, *src = NULL, *p;
@@ -67,10 +67,10 @@
+ src = malloc(len);
+#endif
+
- rc = sscanf(s, "%u " /* (1) id */
- "%u " /* (2) parent */
+ rc = sscanf(s, "%d " /* (1) id */
+ "%d " /* (2) parent */
"%u:%u " /* (3) maj:min */
-@@ -147,9 +176,15 @@ static int mnt_parse_mountinfo_line(stru
+@@ -138,9 +167,15 @@ static int mnt_parse_mountinfo_line(stru
&fs->id,
&fs->parent,
&maj, &min,
@@ -86,7 +86,7 @@
&end);
if (rc >= 7 && end > 0)
-@@ -169,9 +204,15 @@ static int mnt_parse_mountinfo_line(stru
+@@ -160,9 +195,15 @@ static int mnt_parse_mountinfo_line(stru
UL_SCNsA" " /* (9) source */
UL_SCNsA, /* (10) fs options (fs specific) */
@@ -101,4 +101,4 @@
+#endif
if (rc >= 10) {
- fs->flags |= MNT_FS_KERNEL;
+ size_t sz;