aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/jboot-tools/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'package/utils/jboot-tools/src/CMakeLists.txt')
-rw-r--r--package/utils/jboot-tools/src/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/utils/jboot-tools/src/CMakeLists.txt b/package/utils/jboot-tools/src/CMakeLists.txt
new file mode 100644
index 0000000000..98fbab38dc
--- /dev/null
+++ b/package/utils/jboot-tools/src/CMakeLists.txt
@@ -0,0 +1,11 @@
+cmake_minimum_required(VERSION 2.6)
+
+PROJECT(jboot-tools C)
+ADD_DEFINITIONS(-Wall -Werror --std=gnu99 -Wmissing-declarations)
+
+SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")
+
+ADD_EXECUTABLE(jboot_config_read jboot_config_read.c)
+TARGET_LINK_LIBRARIES(jboot_config_read)
+
+INSTALL(TARGETS jboot_config_read RUNTIME DESTINATION bin)