aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/f2fs-tools/patches
diff options
context:
space:
mode:
Diffstat (limited to 'package/utils/f2fs-tools/patches')
-rw-r--r--package/utils/f2fs-tools/patches/100-configure.ac-fix-AC_ARG_WITH.patch88
-rw-r--r--package/utils/f2fs-tools/patches/101-configure.ac-fix-cross-compilation.patch80
2 files changed, 0 insertions, 168 deletions
diff --git a/package/utils/f2fs-tools/patches/100-configure.ac-fix-AC_ARG_WITH.patch b/package/utils/f2fs-tools/patches/100-configure.ac-fix-AC_ARG_WITH.patch
deleted file mode 100644
index a7fb50a63d..0000000000
--- a/package/utils/f2fs-tools/patches/100-configure.ac-fix-AC_ARG_WITH.patch
+++ /dev/null
@@ -1,88 +0,0 @@
-From 9af8ee5baceab59d46154c96da62b52935f363fe Mon Sep 17 00:00:00 2001
-From: Nick Hainke <vincent@systemli.org>
-Date: Mon, 27 Jun 2022 20:43:11 +0200
-Subject: [PATCH] configure.ac: fix AC_ARG_WITH
-
-In the new version the configuration no longer respects the
---without/--with blkid/selinux parameters. Add the tests for
-"with_blkid" and "with_selinux" back to configure.ac as described
-in the manual.
-
-Link: https://www.gnu.org/software/autoconf/manual/autoconf-2.60/html_node/External-Software.html
-
-Fixes: c48335416a09 ("configure.ac: Enable cross-compilation")
-
-Signed-off-by: Nick Hainke <vincent@systemli.org>
----
- configure.ac | 44 ++++++++++++++++++++++++++++++--------------
- 1 file changed, 30 insertions(+), 14 deletions(-)
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -39,12 +39,16 @@ AM_INIT_AUTOMAKE([-Wall -Werror foreign
-
- # Test configure options.
- AC_ARG_WITH([selinux],
-- AS_HELP_STRING([--without-selinux],
-- [Ignore presence of libselinux and disable selinux support]))
-+ [AS_HELP_STRING([--without-selinux],
-+ [Ignore presence of libselinux and disable selinux support])],
-+ [],
-+ [with_selinux=check])
-
- AC_ARG_WITH([blkid],
-- AS_HELP_STRING([--without-blkid],
-- [Ignore presence of libblkid and disable blkid support]))
-+ [AS_HELP_STRING([--without-blkid],
-+ [Ignore presence of libblkid and disable blkid support])],
-+ [],
-+ [with_blkid=check])
-
- # Checks for programs.
- AC_PROG_CC
-@@ -55,11 +59,17 @@ AC_PATH_PROG([LDCONFIG], [ldconfig],
- [$PATH:/sbin])
-
- # Checks for libraries.
--AC_CHECK_LIB([blkid], [blkid_probe_all],
-- [AC_SUBST([libblkid_LIBS], ["-lblkid"])
-- AC_DEFINE([HAVE_LIBBLKID], [1],
-- [Define if you have libblkid])
-- ], [], [])
-+AS_IF([test "x$with_blkid" != xno],
-+ [AC_CHECK_LIB([blkid], [blkid_probe_all],
-+ [AC_SUBST([libblkid_LIBS], ["-lblkid"])
-+ AC_DEFINE([HAVE_LIBBLKID], [1],
-+ [Define if you have libblkid])
-+ ],
-+ [if test "x$with_blkid" != xcheck; then
-+ AC_MSG_FAILURE(
-+ [--with-blkid was given, but test for blkid failed])
-+ fi
-+ ], -lblkid)])
-
- AC_CHECK_LIB([lzo2], [main],
- [AC_SUBST([liblzo2_LIBS], ["-llzo2"])
-@@ -73,11 +83,17 @@ AC_CHECK_LIB([lz4], [main],
- [Define if you have liblz4])
- ], [], [])
-
--AC_CHECK_LIB([selinux], [getcon],
-- [AC_SUBST([libselinux_LIBS], ["-lselinux"])
-- AC_DEFINE([HAVE_LIBSELINUX], [1],
-- [Define if you have libselinux])
-- ], [], [])
-+AS_IF([test "x$with_selinux" != xno],
-+ [AC_CHECK_LIB([selinux], [getcon],
-+ [AC_SUBST([libselinux_LIBS], ["-lselinux"])
-+ AC_DEFINE([HAVE_LIBSELINUX], [1],
-+ [Define if you have libselinux])
-+ ],
-+ [if test "x$with_selinux" != xcheck; then
-+ AC_MSG_FAILURE(
-+ [--with-selinux was given, but test for selinux failed])
-+ fi
-+ ], -lselinux)])
-
- AC_CHECK_LIB([uuid], [uuid_clear],
- [AC_SUBST([libuuid_LIBS], ["-luuid"])
diff --git a/package/utils/f2fs-tools/patches/101-configure.ac-fix-cross-compilation.patch b/package/utils/f2fs-tools/patches/101-configure.ac-fix-cross-compilation.patch
deleted file mode 100644
index b9edd6634b..0000000000
--- a/package/utils/f2fs-tools/patches/101-configure.ac-fix-cross-compilation.patch
+++ /dev/null
@@ -1,80 +0,0 @@
-From 821a1d3fcce31c234512a8f4dc4fc97dfbd7ae32 Mon Sep 17 00:00:00 2001
-From: Nick Hainke <vincent@systemli.org>
-Date: Mon, 4 Jul 2022 09:46:10 +0200
-Subject: [PATCH] configure.ac: fix cross compilation
-
-AC_CHECK_LIB seems to not work correctly with OpenWrt. Add possibility
-to disable lz4 and lzo2 manually.
-
-Fixes errors in the form of:
- Package f2fsck is missing dependencies for the following libraries:
- liblz4.so.1
- liblzo2.so.2
-
-Signed-off-by: Nick Hainke <vincent@systemli.org>
----
- configure.ac | 44 ++++++++++++++++++++++++++++++++++----------
- 1 file changed, 34 insertions(+), 10 deletions(-)
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -50,6 +50,18 @@ AC_ARG_WITH([blkid],
- [],
- [with_blkid=check])
-
-+AC_ARG_WITH([lzo2],
-+ [AS_HELP_STRING([--without-lzo2],
-+ [Ignore presence of liblzo2 and disable lzo2 support])],
-+ [],
-+ [with_lzo2=check])
-+
-+AC_ARG_WITH([lz4],
-+ [AS_HELP_STRING([--without-lz4],
-+ [Ignore presence of liblz4 and disable lz4 support])],
-+ [],
-+ [with_lz4=check])
-+
- # Checks for programs.
- AC_PROG_CC
- AM_PROG_AR
-@@ -71,17 +83,29 @@ AS_IF([test "x$with_blkid" != xno],
- fi
- ], -lblkid)])
-
--AC_CHECK_LIB([lzo2], [main],
-- [AC_SUBST([liblzo2_LIBS], ["-llzo2"])
-- AC_DEFINE([HAVE_LIBLZO2], [1],
-- [Define if you have liblzo2])
-- ], [], [])
--
--AC_CHECK_LIB([lz4], [main],
-- [AC_SUBST([liblz4_LIBS], ["-llz4"])
-- AC_DEFINE([HAVE_LIBLZ4], [1],
-- [Define if you have liblz4])
-- ], [], [])
-+AS_IF([test "x$with_lzo2" != xno],
-+ [AC_CHECK_LIB([lzo2], [main],
-+ [AC_SUBST([liblzo2_LIBS], ["-llzo2"])
-+ AC_DEFINE([HAVE_LIBLZO2], [1],
-+ [Define if you have liblzo2])
-+ ],
-+ [if test "x$with_lzo2" != xcheck; then
-+ AC_MSG_FAILURE(
-+ [--with-lzo2 was given, but test for lzo2 failed])
-+ fi
-+ ], -llzo2)])
-+
-+AS_IF([test "x$with_lz4" != xno],
-+ [AC_CHECK_LIB([lz4], [main],
-+ [AC_SUBST([liblz4_LIBS], ["-llz4"])
-+ AC_DEFINE([HAVE_LIBLZ4], [1],
-+ [Define if you have liblz4])
-+ ],
-+ [if test "x$with_lz4" != xcheck; then
-+ AC_MSG_FAILURE(
-+ [--with-lz4 was given, but test for lz4 failed])
-+ fi
-+ ], -llz4)])
-
- AS_IF([test "x$with_selinux" != xno],
- [AC_CHECK_LIB([selinux], [getcon],