aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/bcm27xx-userland/patches/0001-Revert-Add-MMAL-and-MMAL_APPS-to-64bit-builds.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/utils/bcm27xx-userland/patches/0001-Revert-Add-MMAL-and-MMAL_APPS-to-64bit-builds.patch')
-rw-r--r--package/utils/bcm27xx-userland/patches/0001-Revert-Add-MMAL-and-MMAL_APPS-to-64bit-builds.patch75
1 files changed, 75 insertions, 0 deletions
diff --git a/package/utils/bcm27xx-userland/patches/0001-Revert-Add-MMAL-and-MMAL_APPS-to-64bit-builds.patch b/package/utils/bcm27xx-userland/patches/0001-Revert-Add-MMAL-and-MMAL_APPS-to-64bit-builds.patch
new file mode 100644
index 0000000000..89295c9ff0
--- /dev/null
+++ b/package/utils/bcm27xx-userland/patches/0001-Revert-Add-MMAL-and-MMAL_APPS-to-64bit-builds.patch
@@ -0,0 +1,75 @@
+From 39c946b5dfcc38d3b2cd16d9c96f47a8341387cd Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?=C3=81lvaro=20Fern=C3=A1ndez=20Rojas?= <noltari@gmail.com>
+Date: Thu, 28 May 2020 15:19:57 +0200
+Subject: [PATCH] Revert "Add MMAL and MMAL_APPS to 64bit builds"
+
+This reverts commit 7d3c6b9f4c3ddeecefdeb2b882bada74a235249b.
+---
+ CMakeLists.txt | 18 ++++++++++--------
+ host_applications/linux/CMakeLists.txt | 4 ++--
+ interface/mmal/CMakeLists.txt | 6 ++----
+ 3 files changed, 14 insertions(+), 14 deletions(-)
+
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -8,9 +8,13 @@ SET(PROJECT_VER_PATCH 0)
+ SET(PROJECT_VER "${PROJECT_VER_MAJOR}.${PROJECT_VER_MINOR}.${PROJECT_VER_PATCH}")
+ SET(PROJECT_APIVER "${PROJECT_VER}")
+
+-set(BUILD_MMAL TRUE)
+-set(BUILD_MMAL_APPS TRUE)
+-
++if(ARM64)
++ set(BUILD_MMAL FALSE)
++ set(BUILD_MMAL_APPS FALSE)
++else()
++ set(BUILD_MMAL TRUE)
++ set(BUILD_MMAL_APPS TRUE)
++endif()
+ set(vmcs_root ${PROJECT_SOURCE_DIR})
+ get_filename_component(VIDEOCORE_ROOT . ABSOLUTE)
+
+@@ -74,11 +78,9 @@ if(BUILD_MMAL)
+ endif()
+
+ # VidTex supports Android and Linux
+-if(NOT ARM64)
+- if(BUILD_MMAL_APPS)
+- add_subdirectory(host_applications/android/apps/vidtex)
+- endif(BUILD_MMAL_APPS)
+-endif()
++if(BUILD_MMAL_APPS)
++add_subdirectory(host_applications/android/apps/vidtex)
++endif(BUILD_MMAL_APPS)
+
+ if(NOT ARM64)
+ add_subdirectory(middleware/openmaxil)
+--- a/host_applications/linux/CMakeLists.txt
++++ b/host_applications/linux/CMakeLists.txt
+@@ -4,9 +4,9 @@ add_subdirectory(libs/bcm_host)
+ add_subdirectory(apps/gencmd)
+ add_subdirectory(apps/tvservice)
+ add_subdirectory(apps/vcmailbox)
+-add_subdirectory(apps/raspicam)
+-add_subdirectory(libs/sm)
+ if(NOT ARM64)
++ add_subdirectory(apps/raspicam)
++ add_subdirectory(libs/sm)
+ add_subdirectory(apps/smem)
+ endif()
+ add_subdirectory(libs/debug_sym)
+--- a/interface/mmal/CMakeLists.txt
++++ b/interface/mmal/CMakeLists.txt
+@@ -11,10 +11,8 @@ add_subdirectory(core)
+ add_subdirectory(util)
+ add_subdirectory(vc)
+ add_subdirectory(components)
+-if(NOT ARM64)
+- add_subdirectory(openmaxil)
+- add_subdirectory(client)
+-endif()
++add_subdirectory(openmaxil)
++add_subdirectory(client)
+
+ target_link_libraries(mmal mmal_core mmal_util mmal_vc_client vcos mmal_components)
+