aboutsummaryrefslogtreecommitdiffstats
path: root/package/utils/bcm27xx-userland/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/utils/bcm27xx-userland/Makefile')
-rw-r--r--package/utils/bcm27xx-userland/Makefile34
1 files changed, 30 insertions, 4 deletions
diff --git a/package/utils/bcm27xx-userland/Makefile b/package/utils/bcm27xx-userland/Makefile
index 098c039f1f..b38e11d074 100644
--- a/package/utils/bcm27xx-userland/Makefile
+++ b/package/utils/bcm27xx-userland/Makefile
@@ -8,16 +8,18 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=bcm27xx-userland
-PKG_VERSION:=4a0a19b88b43e48c6b51b526b9378289fb712a4c
+PKG_VERSION:=3fd8527eefd8790b4e8393458efc5f94eb21a615
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/raspberrypi/userland/tar.gz/$(PKG_VERSION)?
-PKG_HASH:=0f42d48095d1f680cbe8781c2e974b76bdd0507aaef64cce8b8b472ca3a09588
+PKG_HASH:=7de1527d8e9bb7632f68aa083d3b79b44fa711360e3292d59e330e0591c65ebd
PKG_FLAGS:=nonshared
PKG_MAINTAINER:=Álvaro Fernández Rojas <noltari@gmail.com>
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENCE
CMAKE_INSTALL:=1
CMAKE_OPTIONS+=-DVMCS_INSTALL_PREFIX=/usr
@@ -46,6 +48,19 @@ define Package/bcm27xx-userland/description
BCM27xx userland tools including vcgencmd and tvservice.
endef
+define Package/bcm27xx-userland-dev
+ SECTION:=devel
+ CATEGORY:=Development
+ SUBMENU:=Libraries
+ DEPENDS:=@TARGET_bcm27xx +bcm27xx-userland
+ TITLE:=Development files of BCM27xx userland tools
+endef
+
+define Package/bcm27xx-userland-dev/description
+ This package contains the header and static libraries of
+ the BCM27xx userland tools.
+endef
+
define Package/bcm27xx-userland/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/dtmerge $(1)/usr/bin
@@ -61,11 +76,22 @@ endif
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/vcgencmd $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/vcmailbox $(1)/usr/bin
+ $(INSTALL_DIR) $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so $(1)/usr/lib/
+ifneq ($(ARCH),aarch64)
+ $(INSTALL_DIR) $(1)/usr/lib/plugins
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/plugins/ $(1)/usr/lib/
+endif
+endef
+
+define Package/bcm27xx-userland-dev/install
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/ $(1)/usr/
- $(INSTALL_DIR) $(1)/usr/lib
- $(CP) $(PKG_INSTALL_DIR)/usr/lib/ $(1)/usr/
+ $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig $(1)/usr/lib/
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/*.a $(1)/usr/lib/
endef
$(eval $(call BuildPackage,bcm27xx-userland))
+$(eval $(call BuildPackage,bcm27xx-userland-dev))