aboutsummaryrefslogtreecommitdiffstats
path: root/package/uclibc++/patches/002-path_to_bash.patch
diff options
context:
space:
mode:
Diffstat (limited to 'package/uclibc++/patches/002-path_to_bash.patch')
-rw-r--r--package/uclibc++/patches/002-path_to_bash.patch12
1 files changed, 12 insertions, 0 deletions
diff --git a/package/uclibc++/patches/002-path_to_bash.patch b/package/uclibc++/patches/002-path_to_bash.patch
new file mode 100644
index 0000000000..05d0e6ff42
--- /dev/null
+++ b/package/uclibc++/patches/002-path_to_bash.patch
@@ -0,0 +1,12 @@
+diff -ur old/bin/Makefile dev/bin/Makefile
+--- old/bin/Makefile Sat Oct 14 17:49:54 2006
++++ dev/bin/Makefile Sat Oct 14 17:57:33 2006
+@@ -13,7 +13,7 @@
+ $(INSTALL) -m 755 $(WRAPPER) $(PREFIX)$(UCLIBCXX_RUNTIME_BINDIR)
+
+ $(WRAPPER):
+- echo '#!/bin/sh' > $(WRAPPER)
++ echo '#!/usr/bin/env bash' > $(WRAPPER)
+ echo '' >> $(WRAPPER)
+ echo 'WRAPPER_INCLUDEDIR="$${WRAPPER_INCLUDEDIR:=-I$(UCLIBCXX_RUNTIME_INCLUDEDIR)}"' >> $(WRAPPER)
+ echo 'WRAPPER_LIBDIR="$${WRAPPER_LIBDIR:=-L$(UCLIBCXX_RUNTIME_LIBDIR)}"' >> $(WRAPPER)