aboutsummaryrefslogtreecommitdiffstats
path: root/package/system
diff options
context:
space:
mode:
Diffstat (limited to 'package/system')
-rw-r--r--package/system/fstools/Makefile3
-rw-r--r--package/system/procd/Makefile3
-rw-r--r--package/system/ubox/Makefile6
3 files changed, 4 insertions, 8 deletions
diff --git a/package/system/fstools/Makefile b/package/system/fstools/Makefile
index f7cb17461c..f716f26c05 100644
--- a/package/system/fstools/Makefile
+++ b/package/system/fstools/Makefile
@@ -31,7 +31,6 @@ PKG_MAINTAINER:=John Crispin <john@phrozen.org>
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
-TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
CMAKE_OPTIONS += $(if $(CONFIG_FSTOOLS_UBIFS_EXTROOT),-DCMAKE_UBIFS_EXTROOT=y)
CMAKE_OPTIONS += $(if $(CONFIG_FSTOOLS_OVL_MOUNT_FULL_ACCESS_TIME),-DCMAKE_OVL_MOUNT_FULL_ACCESS_TIME=y)
CMAKE_OPTIONS += $(if $(CONFIG_FSTOOLS_OVL_MOUNT_COMPRESS_ZLIB),-DCMAKE_OVL_MOUNT_COMPRESS_ZLIB=y)
@@ -39,7 +38,7 @@ CMAKE_OPTIONS += $(if $(CONFIG_FSTOOLS_OVL_MOUNT_COMPRESS_ZLIB),-DCMAKE_OVL_MOUN
define Package/fstools
SECTION:=base
CATEGORY:=Base system
- DEPENDS:=+ubox +USE_GLIBC:librt +NAND_SUPPORT:ubi-utils
+ DEPENDS:=+ubox +NAND_SUPPORT:ubi-utils
TITLE:=OpenWrt filesystem tools
MENU:=1
endef
diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index 5e9733675a..2eebe50a4f 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -35,7 +35,6 @@ ifeq ($(DUMP),)
endif
CMAKE_OPTIONS += -DEARLY_PATH="$(TARGET_INIT_PATH)"
-TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
TARGET_CFLAGS += -flto
TARGET_LDFLAGS += -flto
@@ -43,7 +42,7 @@ TARGET_LDFLAGS += -flto
define Package/procd/Default
SECTION:=base
CATEGORY:=Base system
- DEPENDS:=+ubusd +ubus +libjson-script +ubox +USE_GLIBC:librt +libubox \
+ DEPENDS:=+ubusd +ubus +libjson-script +ubox +libubox \
+libubus +libblobmsg-json +libjson-c +jshn
TITLE:=OpenWrt system process manager
USERID:=:dialout=20 :audio=29
diff --git a/package/system/ubox/Makefile b/package/system/ubox/Makefile
index ca177b2c49..1030c14bb1 100644
--- a/package/system/ubox/Makefile
+++ b/package/system/ubox/Makefile
@@ -18,12 +18,10 @@ PKG_MAINTAINER:=John Crispin <john@phrozen.org>
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
-TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
-
define Package/ubox
SECTION:=base
CATEGORY:=Base system
- DEPENDS:=+libubox +ubusd +ubus +libubus +libuci +USE_GLIBC:librt
+ DEPENDS:=+libubox +ubusd +ubus +libubus +libuci
TITLE:=OpenWrt system helper toolbox
ALTERNATIVES:=\
100:/sbin/rmmod:/sbin/kmodloader \
@@ -46,7 +44,7 @@ endef
define Package/logd
SECTION:=base
CATEGORY:=Base system
- DEPENDS:=+libubox +libubus +libblobmsg-json +USE_GLIBC:librt
+ DEPENDS:=+libubox +libubus +libblobmsg-json
TITLE:=OpenWrt system log implementation
USERID:=logd=514:logd=514
endef