aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/ubox/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/system/ubox/Makefile')
-rw-r--r--package/system/ubox/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/package/system/ubox/Makefile b/package/system/ubox/Makefile
index ca177b2c49..1030c14bb1 100644
--- a/package/system/ubox/Makefile
+++ b/package/system/ubox/Makefile
@@ -18,12 +18,10 @@ PKG_MAINTAINER:=John Crispin <john@phrozen.org>
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
-TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
-
define Package/ubox
SECTION:=base
CATEGORY:=Base system
- DEPENDS:=+libubox +ubusd +ubus +libubus +libuci +USE_GLIBC:librt
+ DEPENDS:=+libubox +ubusd +ubus +libubus +libuci
TITLE:=OpenWrt system helper toolbox
ALTERNATIVES:=\
100:/sbin/rmmod:/sbin/kmodloader \
@@ -46,7 +44,7 @@ endef
define Package/logd
SECTION:=base
CATEGORY:=Base system
- DEPENDS:=+libubox +libubus +libblobmsg-json +USE_GLIBC:librt
+ DEPENDS:=+libubox +libubus +libblobmsg-json
TITLE:=OpenWrt system log implementation
USERID:=logd=514:logd=514
endef