aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/rpcd/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/system/rpcd/Makefile')
-rw-r--r--package/system/rpcd/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/system/rpcd/Makefile b/package/system/rpcd/Makefile
index 2827e955db..9b1f239623 100644
--- a/package/system/rpcd/Makefile
+++ b/package/system/rpcd/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=rpcd
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/rpcd.git
@@ -84,6 +84,11 @@ define BuildPlugin
$(3)
endef
+ define Package/rpcd-mod-$(1)/postinst
+#!/bin/sh
+[ -n "$$$${IPKG_INSTROOT}" ] || /etc/init.d/rpcd reload
+ endef
+
define Package/rpcd-mod-$(1)/install
$(INSTALL_DIR) $$(1)/usr/lib/rpcd
$(INSTALL_BIN) $(PKG_BUILD_DIR)/$(1).so $$(1)/usr/lib/rpcd/