aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/procd
diff options
context:
space:
mode:
Diffstat (limited to 'package/system/procd')
-rw-r--r--package/system/procd/Makefile4
-rw-r--r--package/system/procd/files/procd.sh5
2 files changed, 5 insertions, 4 deletions
diff --git a/package/system/procd/Makefile b/package/system/procd/Makefile
index f31c8d0cea..29a6008160 100644
--- a/package/system/procd/Makefile
+++ b/package/system/procd/Makefile
@@ -13,8 +13,8 @@ PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL=$(PROJECT_GIT)/project/procd.git
PKG_SOURCE_DATE:=2019-05-02
-PKG_SOURCE_VERSION:=61a8be6cb4423dde9c7e7262456f4a16752b9abc
-PKG_MIRROR_HASH:=6020e59d1a2983a5039e10fd1f5e7b89f229fefecdff9472729709fccc7cdf43
+PKG_SOURCE_VERSION:=455aca9b9a0c2d603121a7bcae43abd486762bab
+PKG_MIRROR_HASH:=81cd790390a523ea458a7e4f97ebe1a08e68e31b758f1dca81efd1cb8a77d057
CMAKE_INSTALL:=1
PKG_LICENSE:=GPL-2.0
diff --git a/package/system/procd/files/procd.sh b/package/system/procd/files/procd.sh
index 6115f0702f..b49b2b9d01 100644
--- a/package/system/procd/files/procd.sh
+++ b/package/system/procd/files/procd.sh
@@ -18,7 +18,8 @@
# file: configuration files (array)
# netdev: bound network device (detects ifindex changes)
# limits: resource limits (passed to the process)
-# user info: array with 1 values $username
+# user: $username to run service as
+# group: $groupname to run service as
# pidfile: file name to write pid into
# stdout: boolean whether to redirect commands stdout to syslog (default: 0)
# stderr: boolean whether to redirect commands stderr to syslog (default: 0)
@@ -252,7 +253,7 @@ _procd_set_param() {
reload_signal)
json_add_int "$type" $(kill -l "$1")
;;
- pidfile|user|seccomp|capabilities|facility)
+ pidfile|user|group|seccomp|capabilities|facility)
json_add_string "$type" "$1"
;;
stdout|stderr|no_new_privs)