aboutsummaryrefslogtreecommitdiffstats
path: root/package/system/opkg/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/system/opkg/Makefile')
-rw-r--r--package/system/opkg/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/package/system/opkg/Makefile b/package/system/opkg/Makefile
index 83c9dab1b0..1841e190e6 100644
--- a/package/system/opkg/Makefile
+++ b/package/system/opkg/Makefile
@@ -28,6 +28,8 @@ PKG_CONFIG_DEPENDS += \
HOST_BUILD_DEPENDS:=libubox/host
+PKG_BUILD_FLAGS:=gc-sections
+
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/host-build.mk
include $(INCLUDE_DIR)/cmake.mk
@@ -57,7 +59,6 @@ define Package/opkg/conffiles
/etc/opkg/customfeeds.conf
endef
-TARGET_CFLAGS += -ffunction-sections -fdata-sections
EXTRA_CFLAGS += $(TARGET_CPPFLAGS)
CMAKE_OPTIONS += \