aboutsummaryrefslogtreecommitdiffstats
path: root/package/ppp
diff options
context:
space:
mode:
Diffstat (limited to 'package/ppp')
-rw-r--r--package/ppp/Makefile2
-rwxr-xr-xpackage/ppp/files/etc/ppp/ip-up3
2 files changed, 4 insertions, 1 deletions
diff --git a/package/ppp/Makefile b/package/ppp/Makefile
index 919e105bbb..893c84dfea 100644
--- a/package/ppp/Makefile
+++ b/package/ppp/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ppp
PKG_VERSION:=2.4.4
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=ftp://ftp.samba.org/pub/ppp/
diff --git a/package/ppp/files/etc/ppp/ip-up b/package/ppp/files/etc/ppp/ip-up
index 46c8d37700..ecdd00b1c4 100755
--- a/package/ppp/files/etc/ppp/ip-up
+++ b/package/ppp/files/etc/ppp/ip-up
@@ -13,6 +13,9 @@ export PPP_IFACE PPP_TTY PPP_SPEED PPP_LOCAL PPP_REMOTE PPP_IPPARAM
uci_set_state network "$PPP_IPPARAM" unit "$PPP_UNIT"
uci_set_state network "$PPP_IPPARAM" ipaddr "$PPP_LOCAL"
uci_set_state network "$PPP_IPPARAM" gateway "$PPP_REMOTE"
+
+ local dns="$DNS1${DNS2:+ $DNS2}"
+ [ -n "$dns" ] && uci_set_state network "$PPP_IPPARAM" dns "$dns"
}
[ -z "$PPP_IPPARAM" ] || env -i ACTION="ifup" INTERFACE="$PPP_IPPARAM" DEVICE="$PPP_IFACE" PROTO=ppp /sbin/hotplug-call "iface"