aboutsummaryrefslogtreecommitdiffstats
path: root/package/openssl
diff options
context:
space:
mode:
Diffstat (limited to 'package/openssl')
-rw-r--r--package/openssl/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index 11a9ef2e28..55c9a1c623 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -93,8 +93,9 @@ endef
TARGET_CFLAGS += $(FPIC)
define Build/Compile
- rm -rf $(PKG_INSTALL_DIR)
- mkdir -p $(PKG_INSTALL_DIR)
+ # XXX: OpenSSL "make depend" will look for installed headers before its own,
+ # so remove installed stuff first
+ -$(SUBMAKE) -j1 clean-staging
$(MAKE) -C $(PKG_BUILD_DIR) \
MAKEDEPPROG="$(TARGET_CROSS)gcc" \
OPENWRT_OPTIMIZATION_FLAGS="$(TARGET_CFLAGS)" \