aboutsummaryrefslogtreecommitdiffstats
path: root/package/openssl
diff options
context:
space:
mode:
Diffstat (limited to 'package/openssl')
-rw-r--r--package/openssl/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index a696dd7cd4..7043aeeb18 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -82,11 +82,16 @@ else
OPENSSL_OPTIONS += no-engines
endif
-OPENSSL_OPTIONS += no-perlasm
+ifeq ($(CONFIG_x86_64),y)
+ OPENSSL_TARGET:=linux-x86_64
+else
+ OPENSSL_TARGET:=linux-openwrt
+ OPENSSL_OPTIONS+=no-perlasm no-sse2
+endif
define Build/Configure
(cd $(PKG_BUILD_DIR); \
- ./Configure linux-openwrt \
+ ./Configure $(OPENSSL_TARGET) \
--prefix=/usr \
--openssldir=/etc/ssl \
$(TARGET_CPPFLAGS) \