aboutsummaryrefslogtreecommitdiffstats
path: root/package/openssl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/openssl/Makefile')
-rw-r--r--package/openssl/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/package/openssl/Makefile b/package/openssl/Makefile
index d95783aac9..cfc3b3d92d 100644
--- a/package/openssl/Makefile
+++ b/package/openssl/Makefile
@@ -88,8 +88,13 @@ endif
ifeq ($(CONFIG_x86_64),y)
OPENSSL_TARGET:=linux-x86_64
else
- OPENSSL_TARGET:=linux-openwrt
- OPENSSL_OPTIONS+=no-perlasm no-sse2
+ OPENSSL_OPTIONS+=no-sse2
+ ifeq ($(CONFIG_mips)$(CONFIG_mipsel),y)
+ OPENSSL_TARGET:=linux-mips-openwrt
+ else
+ OPENSSL_TARGET:=linux-generic-openwrt
+ OPENSSL_OPTIONS+=no-perlasm
+ endif
endif
define Build/Configure