aboutsummaryrefslogtreecommitdiffstats
path: root/package/odhcp6c
diff options
context:
space:
mode:
Diffstat (limited to 'package/odhcp6c')
-rw-r--r--package/odhcp6c/Makefile4
-rwxr-xr-xpackage/odhcp6c/files/dhcpv6.sh6
2 files changed, 6 insertions, 4 deletions
diff --git a/package/odhcp6c/Makefile b/package/odhcp6c/Makefile
index 6b960bacb1..4e1ecd35ab 100644
--- a/package/odhcp6c/Makefile
+++ b/package/odhcp6c/Makefile
@@ -8,14 +8,14 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=odhcp6c
-PKG_VERSION:=2013-06-13
+PKG_VERSION:=2013-06-18
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_URL:=git://github.com/sbyx/odhcp6c.git
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=83114b179091cb080f09cf4142ee1c9949ea4e30
+PKG_SOURCE_VERSION:=eaf3a11cad8a5dd389d5f52cc76e424e0242074b
PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
include $(INCLUDE_DIR)/package.mk
diff --git a/package/odhcp6c/files/dhcpv6.sh b/package/odhcp6c/files/dhcpv6.sh
index b2264ed907..c5e77c65b4 100755
--- a/package/odhcp6c/files/dhcpv6.sh
+++ b/package/odhcp6c/files/dhcpv6.sh
@@ -18,8 +18,8 @@ proto_dhcpv6_setup() {
local config="$1"
local iface="$2"
- local reqaddress reqprefix clientid reqopts noslaaconly norelease ip6prefix iface_dslite
- json_get_vars reqaddress reqprefix clientid reqopts noslaaconly norelease ip6prefix iface_dslite
+ local reqaddress reqprefix clientid reqopts noslaaconly norelease ip6prefix iface_dslite ifaceid
+ json_get_vars reqaddress reqprefix clientid reqopts noslaaconly norelease ip6prefix iface_dslite ifaceid
# Configure
@@ -35,6 +35,8 @@ proto_dhcpv6_setup() {
[ "$norelease" = "1" ] && append opts "-k"
+ [ -n "$ifaceid" ] && append opts "-i$ifaceid"
+
for opt in $reqopts; do
append opts "-r$opt"
done