aboutsummaryrefslogtreecommitdiffstats
path: root/package/ocf-crypto-headers
diff options
context:
space:
mode:
Diffstat (limited to 'package/ocf-crypto-headers')
-rw-r--r--package/ocf-crypto-headers/Makefile2
-rw-r--r--package/ocf-crypto-headers/src/cryptodev.h8
2 files changed, 6 insertions, 4 deletions
diff --git a/package/ocf-crypto-headers/Makefile b/package/ocf-crypto-headers/Makefile
index de3ecea22c..fee2a3734f 100644
--- a/package/ocf-crypto-headers/Makefile
+++ b/package/ocf-crypto-headers/Makefile
@@ -7,7 +7,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ocf-crypto-headers
-PKG_VERSION:=20080917
+PKG_VERSION:=20110720
PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)
diff --git a/package/ocf-crypto-headers/src/cryptodev.h b/package/ocf-crypto-headers/src/cryptodev.h
index fa1a57b4f8..cca0ec822d 100644
--- a/package/ocf-crypto-headers/src/cryptodev.h
+++ b/package/ocf-crypto-headers/src/cryptodev.h
@@ -2,8 +2,8 @@
/* $OpenBSD: cryptodev.h,v 1.31 2002/06/11 11:14:29 beck Exp $ */
/*-
- * Linux port done by David McCullough <david_mccullough@securecomputing.com>
- * Copyright (C) 2006-2007 David McCullough
+ * Linux port done by David McCullough <david_mccullough@mcafee.com>
+ * Copyright (C) 2006-2010 David McCullough
* Copyright (C) 2004-2005 Intel Corporation.
* The license and original author are listed below.
*
@@ -156,7 +156,8 @@
#define CRYPTO_SHA2_384 23
#define CRYPTO_SHA2_512 24
#define CRYPTO_RIPEMD160 25
-#define CRYPTO_ALGORITHM_MAX 25 /* Keep updated - see below */
+#define CRYPTO_LZS_COMP 26
+#define CRYPTO_ALGORITHM_MAX 26 /* Keep updated - see above */
/* Algorithm flags */
#define CRYPTO_ALG_FLAG_SUPPORTED 0x01 /* Algorithm is supported */
@@ -336,6 +337,7 @@ struct cryptodesc {
#define crd_key CRD_INI.cri_key
#define crd_alg CRD_INI.cri_alg
#define crd_klen CRD_INI.cri_klen
+#define crd_mlen CRD_INI.cri_mlen
struct cryptodesc *crd_next;
};