aboutsummaryrefslogtreecommitdiffstats
path: root/package/network
diff options
context:
space:
mode:
Diffstat (limited to 'package/network')
-rw-r--r--package/network/utils/nftables/Makefile6
-rw-r--r--package/network/utils/nftables/patches/0001-meta-don-t-use-non-POSIX-formats-in-strptime.patch49
2 files changed, 3 insertions, 52 deletions
diff --git a/package/network/utils/nftables/Makefile b/package/network/utils/nftables/Makefile
index 850355df8d..fd53e3faa1 100644
--- a/package/network/utils/nftables/Makefile
+++ b/package/network/utils/nftables/Makefile
@@ -6,12 +6,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=nftables
-PKG_VERSION:=1.0.4
-PKG_RELEASE:=2
+PKG_VERSION:=1.0.5
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://netfilter.org/projects/$(PKG_NAME)/files
-PKG_HASH:=927fb1fea1f685a328c10cf791eb655d7e1ed49d310eea5cb3101dfd8d6cba35
+PKG_HASH:=8d1b4b18393af43698d10baa25d2b9b6397969beecac7816c35dd0714e4de50a
PKG_MAINTAINER:=
PKG_LICENSE:=GPL-2.0
diff --git a/package/network/utils/nftables/patches/0001-meta-don-t-use-non-POSIX-formats-in-strptime.patch b/package/network/utils/nftables/patches/0001-meta-don-t-use-non-POSIX-formats-in-strptime.patch
deleted file mode 100644
index a9d0ee5451..0000000000
--- a/package/network/utils/nftables/patches/0001-meta-don-t-use-non-POSIX-formats-in-strptime.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-From 1af8aabccd65e11caa397c4706353075f623cd01 Mon Sep 17 00:00:00 2001
-From: Jo-Philipp Wich <jo@mein.io>
-Date: Mon, 8 Aug 2022 23:57:03 +0200
-Subject: [PATCH] meta: don't use non-POSIX formats in strptime()
-
-The current strptime() invocations in meta.c use the `%F` format which
-is not specified by POSIX and thus unimplemented by some libc flavors
-such as musl libc.
-
-Replace all occurrences of `%F` with an equivalent `%Y-%m-%d` format
-in order to be able to properly parse user supplied dates in such
-environments.
-
-Signed-off-by: Jo-Philipp Wich <jo@mein.io>
----
- src/meta.c | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/src/meta.c b/src/meta.c
-index 80ace25b..257bbc9f 100644
---- a/src/meta.c
-+++ b/src/meta.c
-@@ -399,7 +399,7 @@ static void date_type_print(const struct expr *expr, struct output_ctx *octx)
- tstamp += cur_tm->tm_gmtoff;
-
- if ((tm = gmtime((time_t *) &tstamp)) != NULL &&
-- strftime(timestr, sizeof(timestr) - 1, "%F %T", tm))
-+ strftime(timestr, sizeof(timestr) - 1, "%Y-%m-%d %T", tm))
- nft_print(octx, "\"%s\"", timestr);
- else
- nft_print(octx, "Error converting timestamp to printed time");
-@@ -412,11 +412,11 @@ static bool parse_iso_date(uint64_t *tstamp, const char *sym)
-
- memset(&tm, 0, sizeof(struct tm));
-
-- if (strptime(sym, "%F %T", &tm))
-+ if (strptime(sym, "%Y-%m-%d %T", &tm))
- goto success;
-- if (strptime(sym, "%F %R", &tm))
-+ if (strptime(sym, "%Y-%m-%d %R", &tm))
- goto success;
-- if (strptime(sym, "%F", &tm))
-+ if (strptime(sym, "%Y-%m-%d", &tm))
- goto success;
-
- return false;
---
-2.35.1
-