aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/xdp-tools/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/utils/xdp-tools/Makefile')
-rw-r--r--package/network/utils/xdp-tools/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/package/network/utils/xdp-tools/Makefile b/package/network/utils/xdp-tools/Makefile
index 32f302543a..42a8a0695b 100644
--- a/package/network/utils/xdp-tools/Makefile
+++ b/package/network/utils/xdp-tools/Makefile
@@ -85,7 +85,6 @@ CONFIGURE_VARS += \
CFLAGS="$(TARGET_CFLAGS)" \
LDFLAGS="$(TARGET_LDFLAGS)" \
CLANG="$(CLANG)" \
- BPF_CFLAGS="$(BPF_CFLAGS)" \
BPF_TARGET="$(BPF_TARGET)" \
LLC="$(LLVM_LLC)"
@@ -93,6 +92,11 @@ MAKE_VARS += \
PREFIX=/usr \
RUNDIR=/tmp/run
+define Build/Configure
+ $(call Build/Configure/Default)
+ echo "BPF_CFLAGS += -I$(BPF_HEADERS_DIR)/tools/lib" >> $(PKG_BUILD_DIR)/config.mk
+endef
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include/xdp
$(CP) $(PKG_INSTALL_DIR)/usr/include/xdp/*.h $(1)/usr/include/xdp/