aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/umbim
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/utils/umbim')
-rw-r--r--package/network/utils/umbim/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/package/network/utils/umbim/Makefile b/package/network/utils/umbim/Makefile
index 3563949c67..1a09984a43 100644
--- a/package/network/utils/umbim/Makefile
+++ b/package/network/utils/umbim/Makefile
@@ -14,6 +14,7 @@ PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:=
PKG_FLAGS:=nonshared
+PKG_BUILD_FLAGS:=gc-sections
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/cmake.mk
@@ -32,9 +33,7 @@ define Package/umbim/description
endef
TARGET_CFLAGS += \
- -I$(STAGING_DIR)/usr/include -ffunction-sections -fdata-sections
-
-TARGET_LDFLAGS += -Wl,--gc-sections
+ -I$(STAGING_DIR)/usr/include
define Package/umbim/install
$(INSTALL_DIR) $(1)/sbin