aboutsummaryrefslogtreecommitdiffstats
path: root/package/network/utils/owipcalc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'package/network/utils/owipcalc/Makefile')
-rw-r--r--package/network/utils/owipcalc/Makefile44
1 files changed, 0 insertions, 44 deletions
diff --git a/package/network/utils/owipcalc/Makefile b/package/network/utils/owipcalc/Makefile
deleted file mode 100644
index dc68a0346b..0000000000
--- a/package/network/utils/owipcalc/Makefile
+++ /dev/null
@@ -1,44 +0,0 @@
-#
-# Copyright (C) 2012 Jo-Philipp Wich <jo@mein.io>
-#
-# This is free software, licensed under the Apache 2 license.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=owipcalc
-PKG_RELEASE:=5
-PKG_LICENSE:=Apache-2.0
-
-include $(INCLUDE_DIR)/package.mk
-
-
-define Package/owipcalc
- SECTION:=utils
- CATEGORY:=Utilities
- TITLE:=Simple IPv4/IPv6 address calculator
- MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
-endef
-
-define Package/owipcalc/description
- The owipcalc utility supports a number of calculations and tests to work
- with ip-address ranges, this is useful for scripts that e.g. need to
- partition ipv6-prefixes into small subnets or to calculate address ranges
- for dhcp pools.
-endef
-
-define Build/Configure
-endef
-
-define Build/Compile
- $(TARGET_CC) $(TARGET_CFLAGS) \
- -o $(PKG_BUILD_DIR)/owipcalc $(PKG_BUILD_DIR)/owipcalc.c
-endef
-
-
-define Package/owipcalc/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/owipcalc $(1)/usr/bin/owipcalc
-endef
-
-$(eval $(call BuildPackage,owipcalc))